Endless adding to library

Hi Jamie - I am having the same problems @Jeffrey_Smedley described. Using Roon Nucleus and Win10.

The core is endlessly cycling, scanning and updating. During this process (actually,m all the time), Roon is unresponsive (e.g. all tags I place are not saved or displayed).

After a few hundreds of added tracks the process stucks:

Happens over and over and over again (with different numbers of tracks added, though) - - Roon is basically useless now… :-/


Hi @Michael_Putz, can you please do the following:

  • Reboot your Core machine.
  • Start up Roon and let the spinner go for ~5 minutes.
  • Reboot your Core machine once more.
  • Start up Roon and let the spinner go for another ~5 minutes.

This should allow the team to gain some insight into what you’re experiencing in the report. Once you’ve done this let me know the timestamps and use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).

1 Like

Hi @dylan

I am struggeling to find any log files in my library. I am using the Nucleus Core. So, I do not find any file on my Windows PC called “Roon*.*”.

My Nucleus drive is the R:// drive. It is called:

I cannot find any log files there either. What can I do?

Thanks for help.

HI Michael,

You are looking at the wrong thing. It seems like you are looking at a Windows drive mapped to the Internal Storage disk. This is not where the Roon core or the log files live.

Open up file manager and depending on the device you have \\ROCK for a ROCK NUC; \\NUCLEUS for a Nucleus; or \\NUCLEUSPLUS for a Nucleus+. There you should see a folder like this


Under the Data Drive you will find


Under RoonServer, you will find the Logs folder.

Note you might need to use a username/password combo as in point 1 below.

Additionally, I will quote the official Roon FAQ on accessing Logs found here:

Nucleus Core

Be sure to replace NUCLEUS with NUCLEUSPLUS if you have a Nucleus+

  1. Using a Windows machine, open File Explorer and navigate to \NUCLEUS\Data and use Guest as the username and password. You should then see the RoonServer folder.

  2. Using a Mac, open Finder and navigate to smb://NUCLEUS/Data and use Guest as the username and password. You should then see the RoonServer folder.

1 Like

Thanks - found it!

Here’s the dropbox link - does this work for you?


Got it - found it !
Here’s the link - does this work for you?

Got it - here’s the link, does this work for you in this way?


@dylan @Rugby - it seems to me, that I’ve forwarded this message to me (only) instead of forwarding it to you, sorry for beeing a bit confused here…

Here’s the dropbox link.

Thanks for resonse if you can work with that.

@dylan - I’ve forwarded the dropbox link to you last week. In the meantime roon istn’t responding anymore at all… And nothing has changed except for adding other files to the Nucleus harddrive.
I’m completely unnerved, actually…


I have the metadata optimizer running in the background for days (weeks). I can always play music and am happy about every new picture, every new description and many new links.

Some days it hardly moves (difficult assignments), other days like today I make giant steps forward.

The support is a bit overloaded at the moment and apologizes everywhere if it takes a bit longer to solve a problem. I also had one that took weeks to resolve.


Two thoughts

1 Reboot everything including the network gear

2 Do you have any files with accents / unlauts in their file name , these can often cause issues (it looks like you are German so its likely)

Hi there - I do have an open case with @dylan about the Nucleus core (endlessly cycling, scanning and updating). In the meantime Roon isn’t working anymore at all.

Basically, Roon Software doesn’t work as it should (or in the meantime at all) for a week now.



Still the Roon Server Software is “Not Running”.

Tried to reinstall Operating System again. Tried to reboot system.

All the same. Roon is off.

All other systems (PC, LAN, Amp) are online and running as always.


What do you see if you browse in file manager finder to the data folder?

I read here that there is a Roon server that is not running and also a freshly installed Roon Core that is not reaching the server that is not running because of this.

My server is always a second PC. Depending on the solution Windows 10 Core, Linux Core or Rock looks different.

When I read this note, I think someone who has ever restarted a Nucleus must give helping hints.

Hi @Michael_Putz, sorry for the ongoing trouble here. I’ve reached out to our QA team about what I’m seeing in the logs and will follow up ASAP.

Hi @Michael_Putz, the errors we’re seeing are a bit strange and I’m hoping you can try something out:

  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Nucleus’ Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • On the Roon Remotes, press “Use another Core” and connect to the new database

@dylan - Thanks for your feedback here, very much appreciated.
However: Stoppin RoonServer from running in Nucleus’s WebUI unltimately means that I cannot access \NUCLEUS\Data\ "RoonServer”, does it? Or is there another way?
Sorry for maybe asking weird questions…
Best - Michael

@dylan - ah, okay, I’ve checked it. Because I am using the Nucleaus AND the RoonServer wasn’t running anyways, I’ve just followed your other steps - and voila! Roon is “on” & the music files are being added right now… The wheel is spinning - I do hope it’ll stop spinning soon…

Someone in the community mentions that files containing accents or German Umlaute (which is the case, as I am German) may have cause the trouble. Can you see in the LogFiles, what actually caused the trouble? You writte that the data looked “strange” in some way…?

Best - M

Hi @Michael_Putz, have things continued to work okay for you since making this change?

There were some database errors that I hadn’t seen before. I couldn’t tell if it was that the database had gotten into a bad state somehow or if there were broader problems at play. If things have continued to work, it seems like it was the database. I don’t have any specific insight into exactly what triggered this at the moment, but it wasn’t because of accented characters or anything like that.

Hello @dylan

Thank you for your feedback so far. As I’ve been on holidays and back in my music room today for the first time since Sep 12, I’d like to ask for HELP re: restoring my backup (from the former, the old RoonServer to the new one). I do have tagged many hundreds of tracks and albums, so it would be a nightmare if this wont work.
I do have read this instruction here https://help.roonlabs.com/portal/en/kb/articles/backup, however, I’ve unfortunately missed to do the neccessary first step (i.e., I’ve missed the “Login screen” step and “restore backup” button)

How can I restore the old backup anyway? Any solutions on this?

Thank you very much