Endless parade of crashes on iOS

Wut??? LOL.

Hello @Jeff_Nelson & @roy_langford ,

Thank you for sending those logs and for your patience while we’ve had a chance to review them. It looks like your Roon app might be crashing due to running out of memory, but the reason for the memory issue is not clear. Can you confirm if you are still able to reproduce the issue on our latest release, build 933?

I downloaded it last night. So far it hasn’t crashed. Will monitor and report back.

Just crashed browsing the library.

Installed build 933 on iOS and our core and was hoping I can finally start using Roon again… it’s been many months.

Hoped the new build was going to go to make roon usable…

Still crashes.

I’ve been patient but this getting painful.

If Roon is no longer going to support iOS can you just have it removed from the App Store.

1 Like

Are you indicating you see evidence of memory iserver crashing or an iOS device? What specific evidence in logs do you have for that assessment?

Are you suggesting your software may have a memory leak or I have an issue with either hardware or other software in the device? My device is dedicated to Roon so there’s really nothing consuming memory to any meaningful degree outside of Roon.

I downloaded a memory application on the iPhone. Roon does appear to use a lot of memory running the app. You may have a memory leak somewhere.

Hello @Jeff_Nelson / @roy_langford ,

Yes, we are seeing RAM usage creep up and then we assume that the iOS system forcibly kills the Roon app. We are trying to identify common patterns between reports, can you please confirm if either of you have VPN applications installed on the iOS device? This issue might be related to network interfaces if this is the case.

I do not. But I did factory wipe the iOS device over the weekend. Installed 935 and haven’t had a crash since.

Nope no vpn. It’s a new dedicated m1 Mac mini with little else running. If it’s having a memory issue that’s surely more likely to be a Roon memory leak. I find it implausible that it’s my hardware and given the various pieces of hardware I have used over the years and the dogged nature of crashes on iOS devices - dubious.

Also while I appreciate the follow up - the gaps in responses - it’s so inefficient - that it really makes the issue feel rather futile in terms of actual meaningful support.

Apologies for the candor but that’s where I am in this fumbling support scheme.

What line in your logging points to a memory issue? Can you copy it here specifically?

iPhone 11 user with latest iOS; Roon app been crashing more than ever after latest rounds of Roon updates; Roon is freezing and dying on brand new windows 10 machine with tons of RAM ;

Hi @roy_langford ,

Yes, I can copy it below:

04/08 05:24:48 Error: [RAATServer] [discovery] error sending response: operation canceled
04/08 05:24:48 Error: [RAATServer] [discovery] error sending response: operation canceled
04/08 05:24:48 Info: [stats] iOS memory usage: 441 mb
04/08 05:24:48 Trace: [roonbridge] [sood] Refreshing device list
04/08 05:24:49 Info: [stats] iOS memory usage: 478 mb
04/08 05:24:50 Info: [stats] iOS memory usage: 638 mb
04/08 05:24:51 Info: [stats] iOS memory usage: 888 mb
04/08 05:24:52 Info: [stats] iOS memory usage: 1072 mb
04/08 05:24:53 Info: [stats] iOS memory usage: 1266 mb
04/08 05:24:54 Info: [stats] iOS memory usage: 1457 mb
04/08 05:24:55 Info: [stats] iOS memory usage: 1613 mb
04/08 05:24:56 Info: [stats] iOS memory usage: 1801 mb
04/08 05:24:56 Debug: [easyhttp] [4] GET to https://push-manager.roonlabs.net/1/connect returned after 199 ms, status code: 200
04/08 05:24:56 Debug: [push2] request to push manager successful
04/08 05:24:56 Debug: [push2] push connector url received from push manager: ws://push-connector-v2-0.prd-roonlabs-1.prd.roonlabs.net/
04/08 05:24:56 Trace: [push2] connecting to push2 connector at ws://push-connector-v2-0.prd-roonlabs-1.prd.roonlabs.net/
04/08 05:24:57 Trace: [push2] connected to push2 connector at ws://push-connector-v2-0.prd-roonlabs-1.prd.roonlabs.net/
04/08 05:24:58 Debug: [easyhttp] [5] POST to https://device-map.roonlabs.net/1/register returned after 232 ms, status code: 200
04/08 05:24:58 Trace: [devicemap] device map updated
04/08 05:24:58 Info: [stats] iOS memory usage: 1799 mb
04/08 05:25:00 Info: [stats] iOS memory usage: 1776 mb
04/08 05:25:02 Info: [stats] iOS memory usage: 1724 MB
End of file

To give you some insight into the log trace, it looks like RAATServer (which Roon users to communicate with audio devices, including the iPhone internal speakers) has an error communicating, and then after this error, the iOS memory usage jumps over 1GB usage in 8 seconds.

We have been discussing this issue with our dev team, and they have noted that a RAATServer error like the one referenced in the logs can happen when there is an issue with multiple network interfaces being active on iOs (like when using a VPN for example), and now we are trying to determine if this is the case.

Is there no VPN apps installed on the iPhone at all? If you check under iOS Settings → VPN, are there any VPNs configured at all (even if not currently active)?

I responded directly via email but don’t see it here…so I’ll respond directly.

On my iOS devices I do have multiple vpn configurations and only one active (surfshark in this case). I always switch this active vpn off when listening to music via Roon (even though it seems to work perfectly well with it enabled - I never wanted it as an added potential variable for instability).

Thanks for providing the logging. These data are helpful to provide greater context.

After your logs, on my Roon server I did take the opportunity to ensure wireless is disabled (since it’s otherwise connected directly to the router).

Let me know what further action I might take to try and garner reliable stability.

Is this a iPhone thing ?

I use a iPad Pro 12.9 2020 daily as my primary control device plus an old iPad mini , all I see a quick refresh to connect when I activate the app. Not what I would describe as a crash

Sadly my issues have gotten worse. Since the latest update, I am getting cut outs while playing music - regularly. I am at a point of exhaustion with this app and honestly feel like to just giving up, and using Volumio or Lumin full time. I actually began a Tidal trial (after years of Qobuz) and have to admit to really liking Tidal Connect. It sounds great and the best part it seems to always work. No cutouts - no issues - none. I can leverage this method both via my multiple Volumio instances as well as Lumin. Their interface has also gotten leaps better from the last time I tried it as well…

Back to my issue: After all the cutouts - I took the headless M1 Mac mini hosting Roon out my server room and fired up some basic diagnostics. It’s consuming what to me seems like an inordinate amount of memory (given not much else running and how incredibly efficient M1 is normally managing memory) and I now have to wonder whether there is some meaningful Roon software issue on M1.

The problems just feel endless and I am increasingly backed into a corner. I am sinking hours into the process with no relief seemingly on the horizon.

There’s zero way I will opt for the ridiculously overpriced nucleus (if that even runs any better) and when I ran Rock on a NUC - Roon still had issues with my iOS devices crashing all too often.

At this point - I surrender. If I didn’t have a lifetime membership (which I get Roon has no preference for) I would just terminate my membership. I just caught a thread elsewhere here as I lean further into all of this - with the title “is Roon just a marketing promise?

I haven’t read through that one but it’s an insightful and at this point painfully obvious question.