Entire Playlist is not added to Queue

I noticed when I add a Playlist to a queue the number of tracks seem limited and are not all added to the queue. For example, if my Playlist has 367 tracks it only adds 46 tracks. However, this limit is sporadic depending on the number of tracks in a Playlist. Is there a setting somewhere that prevents all tracks from a Playlist to be added to the queue?

Hi @Douglas_L_Smith,

Starting out here, I’d like to take a look at one specific example playlist. Can you share a screenshot of the playlist and the queue screen when you try to shuffle?

Is it always the same amount of tracks added for this playlist when you shuffle or does it change every time?

I am including 2 screenshots, it doesn’t seem to matter if I add the playlist as “shuffle” “add to queue” etc. for this particular playlist of 387 tracks it always adds 46 tracks. However, another playlist of 456 always adds 123 tracks.


So it is always 46 tracks added for the playlist of 387 and always 123 tracks for the playlist of 456. I have another playlist of 153 tracks that always adds 44 tracks. Should I uninstall and reinstall Roon?Let me know if I didn’t provide the correct screenshots, thanks for your help.

Dylan I think I figured it out. I recently had to change my WiFi router and noticed the only tracks in the queue are albums I own, it is missing all Tidal albums. Is this because Roon is not pointing to the correct connection or Tidal? I have access to both but the link must be broken. Noticed I don’t have the Tidal option in the Roon settings, playing around to figure it out!

Roon was not logged into Tidal. Now all tracks are added to the queue. Sorry I didn’t think about the router change since it was a couple of days ago. Anyway maybe this will help someone else with the same issue. Thanks again!

1 Like

Hi @Douglas_L_Smith,

I’m glad you were able to get things working! Happy listening :headphones:

Thanks, love Roon!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.