Entrypoints, the audio entrance to Roon [NEW: Bluetooth support]

To clarify, a Docker for Linux installation is the prerequisite. When that is covered the Extension Manager will find it independent if it is running in a container itself.

2 Likes

No, it doesn’t. The issue with metadata is that I haven’t found a way to inject it in the ogg/flac stream such that Roon will display it.

1 Like

Ok sorted now just had to install docker on dietpi .

1 Like

I think you can inject metadata with ffmpeg.
I would like to know if you can implement a way to use entrypoints to re-encode HLS radio streams that are not supported by Roon.
Now, I am using ffmpeg and Icecast to send it to Roon, but it would be great to have this as extension.
Thanks !

Rocketbroadcaster supports metadata but it causes all sorts of issues when Radio Paradise switched to it but it’s a Windows only encoder. When I tried using ffmpeg it had horrible buffer issues with capturing from alsa sound card and constantly dropped out. You have it working ok?

For what i am using it, ffmpeg is working great. I am not using it to capture from ALSA.
But, I have a script under windows running as a service and it restarts when it hangs.
From my experience, ffmpeg is very powerful and also very hard to manage. You have to find a version that works for what you need to do. For Linux, the better way is to compile it from sources.
I will try some solutions an came back to you with a feedback.
Best regards !

A rapid search gave me this: https://www.npmjs.com/package/icy
Maybe you can give it a try.

Or maybe this: https://github.com/streamio/streamio-ffmpeg ?

I know I have used it in my line of work for about 12 years.

Another broadcast toll i’ve used is B.U.T.T
https://danielnoethen.de/butt/

Were you able to get it al configured and play some tunes?

Yep. Wouldn’t run at 48khz though kept stopping for some reason. Using HifiBerry Digi+ADC so I know it’s capable and had it running higher than that before with liquidsoap. This is quite an old pi 2b+ it’s running on to test it out though. Sounded pretty good to.

1 Like

So after comparing my vinyl playback via my amp then via Roon the HifiBerry robs the sq of a lot. It could also be other things such as the pi, I was running of a battery pack as I do for my headphone system and whilsy It sounds ok on first impression, when I switched back to it via phono stage to my amp it’s night and day. The HifiBerry looses bass and detail and musicality I always though it wasn’t up to much last time I tried it but this has cemented it. Whilst this is a great idea unless you have a really good a2d it’s going to rob what makes vinyl special.

1 Like

Would be helpful if you can provide a log file of such an occurrence. To do this you restart the Audio Entrypoint with logging via the Extension Manager and then when playback stopped you download the log by clicking the Extension Manager @DietPi link in the extensions overview in Roon.

Ok will give that a go. Need to reassemble it all again. ,:slight_smile:

Jan how low were you able to get the latency? Last time I tried this with shairport the latency was too high to be useable.

In my DietPi setup with a HiFiBerry Digi+ I/O the latency is 5 seconds. The extension gives an indication of it.

image

Can you elaborate a bit more on how the latency made it unusable?

This looks windowesk and complex. If it isn’t plug n play on an iMac through my preferred server antipodes, forget it

This looks pretty interesting! In fact, it looks like something I’ve been looking for and I didn’t know it existed. Great!!

But I can’t get it to work…
On my core machine (Win 10) I installed the Roon Extension Manager. Seemed to have run ok (ran as administrator), restarted the PC, and yet Roon>settings>extensions shows nothing but an empty space under Discovered Roon Extensions and nothing within Authorizations.

Where am I missing?

You have to use Linux? Was hoping to use this to stream my turntable to other zones, but that would be running the digital pre of my Parks Audio Puffin through an external soundcard attached to my laptop.

Could I feed the digital out directly to an RPi4 and use that as the entry point?

Hello. I have upgraded to Extension Manager version 0.11.8 and Extension Repository version 0.3.16 but unlike in the video there is no new category for Entrypoints.
I have:

  • System
  • Playback
  • Device Control
  • Remote Control
  • Web/Connectivity
  • Automation
  • Tools

What did I wrong?