Error code -36 when trying to copy music to internal storage


(Marcus Guerrero) #1

My system specs are higher than what is required so that it can be repurposed as a Windows machine in the future.

ROCK
NUC7i7BNH
16GB RAM Crucial (2X8GB) DDR4-2400 SODIMM
Samsung 970 EVO 250GB - NVMe PCIe M.2 2280 SSD - RoonOS
Samsung 860 QVO 1TB 2.5 Inch SATA III Internal SSD - Internal Storage

My network setup is Comcast Modem>AirPort Extreme>ROCK NUC (connected via Ethernet)

I set up my ROCK last night without any problems but now having issues trying to copy my music library to its internal storage.

Right now I have an external USB hard drive attached to the NUC which contains the Roon backups that I restored from. I migrated from my previous Core which was a Mac Mini.

I attempted to drag/drop a folder containing all my music from the external USB drive to the “InternalStorage” folder but kept getting the error, " The Finder can’t complete the operation because some data in “THE NAME OF MY FOLDER” can’t be read or written.
(Error code -36)".

The same error occurs whether I’m copying a folder containing multiple folders of albums or a single folder containing album tracks. I am using a MacBook Pro running most current version of Mojave to access Roon OS Data Directory. I need help solving this issue. For now, I’m using the external USB drive for my music storage. Everything works great except for this issue.

One other minor question, is there a way to change the name of my Core? During the migration from backup, my ROCK retained the name matching my Mac Mini which will remain in my network to be used as a remote. It would be less confusing if could rename my ROCK Core.

Thanks in advance for your assistance.


#2

Let me handle the minor stuff first -
Settings–>Setup

Otherwise, a google returned this -


(Marcus Guerrero) #3

Otherwise, a google returned this -

Thanks, Slim. Just tried this several times. Didn’t work; still getting the same error. :dizzy_face:


#4

Too bad. Tagging @support.


(Marcus Guerrero) #5

Thanks for the help!


(Dylan Caudill) #6

Hi @Marcus_Guerrero,

Are you copying files directly from the external drive to ROCK’s Internal Storage? Can you try copying a file from somewhere on your Mac instead of the external drive and see if the same behavior occurs?


(Marcus Guerrero) #7

Yes.

Looks like I can copy anything on my Mac to the InternalStorage but I get the error when copying from the external drive. I even did a test and created a new folder on the external drive and couldn’t copy it over.

Do you think it may be a disk permissions problem? The external drive is formatted properly and works fine as storage.

Knowing now that I can copy anything from the remote Mac. I can just copy music from my Mac mini instead. I’m doing that right now as I type this and it’s working fine. Still, I’d like to find an answer to this. I just thought it would be faster to copy from the attached external drive.

Can you also answer my other question from my original post? Any way to change the name of my Rock Core?

Thanks for your help!


#8

I told you how to change name.

Let me be clearer-

Settings—>Setup—>Core Name


(Marcus Guerrero) #9

Doh :crazy_face:LOL. Sorry Slim. I totally missed that. I was at work at the time. Big thanks again.


(Dylan Caudill) #10

Hi @Marcus_Guerrero,

Looking into that error, it appears that it may be related to permissions on the external drive. Moving forward, copying directly from the Mac is going to be the best option to get the files onto Internal Storage. If you have any other questions please let us know!


(Marcus Guerrero) #11

Thanks, Dylan. I’m almost positive that’s what I’m dealing with here. I’m going to attach it to my Mac mini and have it ignore permissions and see if that solves it. I will pass on the results should anyone have the same issue in the future. Meanwhile, I’ve already copied my music library to the internal storage. It went faster than I expected; probably because of my fast network and the internal SSD.

Thanks for your help on this!


(system) closed #12

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.