Error connecting to network share: 68

I’ve read what I could find on the forum about this, but the suggestions aren’t working. I have a QNAP 451+ hooked to an Apple Airport Extreme. I can mount it on my Mac and Roon sees the folders that way, but I eventually want to install Roon Server so I need to get it working properly first. I checked in the network settings and have disabled AFP. My network path (as I entered it) is smb://QNAPNAS451/Multimedia/iTunes. The user and pw are correct. I also tried the IP address instead of the NASNAME but get the same thing. Any ideas? Thanks!

@Bryan_McElhaney, are you adding them as watched folders or managed folders folders or as the iTunes library? Have you tried adding a new shared folder on the NAS and then adding it as a watched folder just as a test?


Watched folder. I just added a test folder in a different directory and tried that and got the same thing. Is there a setting on the NAS that maybe isn’t right?

Thanks, Russ.

@Bryan_McElhaney, Can you detail how you are sitting up the folder, it sounds like a permission problem?


@Bryan_McElhaney, check the IP address of the NAS, have a read of this post.


The IP hasn’t changed. But I did fix it! You were on to something about the permissions. I changed the user and pw to admin and it worked. My user name also has admin privileges, but for some reason that didn’t work. Anyway, thanks!

There is a separate permission settings for each specific shared folder. I’d take a look there and check the permissions.
The admin/admin login combo should be fine for troubleshooting this, but not as a longterm solution (security-wise). :wink: