Error message logging into Tidal

Room gives me an error message “Bad username or password” when i attempt to log into Tidal. But these credentials are correct and work to log me into tidal. I have tried rebooting the Core and Tidal. Still no go.

Hi @Seth_Hendon,

Can you try giving your Core machine a reboot? Often times that will resolve this type of issue.


I have the same problem. Rebooting did not work.

I did try rebooting that id d not work.

Hi @Seth_Hendon,

Can you verify that the TIDAL account has an active subscription? In the past we’ve found that, while you can log in on the website, sometimes the subscription isn’t active. You can check this by going to your Subscription page on the TIDAL website and verifying that you have a checkmark like this:

yes, it’s active.
while i was waiting for you to respond (it would be great by the way if there were a telephone support service) I tried uninstalling and then re-installing Roon on my PC. Then I re-signed into Tidal. This worked.

Hi Seth, you probably didn’t need to uninstall / re-install. It might just have needed to have the Tidal cache cleared.

See this link and give it a try if this occurs again.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.