Error message when I try to add HQPlayer

I add the local IP address I click add HQPlayer, I get a success comment, but when I try to play, it says playback failed because “$ couldnt connect to hqplayer.”

please advise.

Have to enable…Network control…upper right side in HQPlayer!

Hi @Steven_Zore,

I would also make sure that Roon and RAATServer are added as exceptions to any firewalls you have in addition to enabling the Network Control. Please let me know if that helps.


Even with the firewall turned off I’m receiving this message.

Have never had an issue playing through HQPlayer previously and haven’t changed any HQP or Roon settings. It was fine two weeks ago when I used it, but something has happened recently to prevent Roon from connecting to HQPlayer.

HQP to DAC is fine, Roon to DAC is fine.

Only possible external causes that come to mind are a) firmware update on QNAP NAS (Roon core), and b) official Windows 10 patches via Windows Update.

Have two other endpoints which get more use so it’s not a showstopper, but still…

Something I haven’t noticed previously is the power icon at top left in the image below. This isn’t present for other endpoints. When clicked it reveals an icon suggesting the link to HQP is broken.

My issue is solved. No shortcoming of Roon’s whatsoever. Apologies to the devs for any perceived slight!

Added an Apple TV to my home network during the week. The range of allocatable IP addresses on my router is restricted. There were no free addresses remaining, so the router performed a reshuffle to accommodate the new device.

Hence my laptop which has had the same IP address for nearly three years was no longer reachable at the old IP setting. Hopefully this helps someone else out.

Hi @Ron_The_Bear,

Glad to hear that the issue was resolved by editing the IP address range on your router! If you would like to do so, I would highly suggest looking into Reserved IP Addresses for each device to ensure that this kind of shuffle around does not occur in the future, this can usually be accessed in your router settings and I would always leave a 20-50 address surplus at the end of your subnet range for any new devices that might be connected.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.