Error on Changing Password to SMB Mount

I encountered a pretty annoying issue today. My music is shared on a Synology NAS via SMB. In the Synology I changed the password for the user account that is used by Roon to mount the SMB drive. I could not for the life of me get Roon to update the credentials of the mount point. Here are all the steps I tried

  • Removing the folders containing my files from Settings > Storage
  • Changing the credentials fo the Shared drive in Settings > Storage > +Add Folder
  • Removing the shared drive and re-adding it in Settings > Storage > +Add Folder
  • Different combinations of the above

No matter what I tried, every time I restarted Roon the old share would be shown and it would default to the old credentials.

I finally solved the problem by changing the password on the Synology for the Roon user back to the original password. Now I have the fun of having Roon re-index all music for an afternoon and loose all my album identifications, likes, composition merges etc.

not sure if this is user error or not but if it is, the settings I needed to find were buried someplace deep.

If you restore a roon backup, presuming you have backed up the system, you will get your changes back.

Hi @natelandau,

As Ged suggested, I would definitely restore a Roon backup to start here. Once things are back to how they were previously we can try to change the NAS password again.

Were you receiving any errors when trying to update the password? If so, what was the error?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.