Error "Playback was interrupted because a track failed to load" with DS720+

Core Machine

Synology DS720+ (RAM2GB+4GB, Intel Celeron J4125, DSM 6.2.4-25556) with latest roon core software.

Network Details

Synology MR2200ac Wi-Fi

Audio Devices

MacBookPro, iPhone, iPad

Description of Issue

Playback was interrupted because a track failed to load, when the filename contains muddy or semi-muddy characters. Music files were located on the volume of Synology DS720+, and mounted without error.

When I changed the roon core from DS720+ to MacBookPro, roon core on the MacBookPro works fine with all music files on DS720+. When I changed the file location (volume) from Synology DS720+ to QNAP TS231+, roon core both on MacBookPro and DS720+ also works fine with all songs.

Only when playing music files on DS720+ with roon core on DS720+ caused this trouble, and I don’t think there is a network configuration issue with the above trials.

Very weird behavior, and appreciate your kind support to solve this.

Thank you very much!

What does that mean? You know:

I don’t use those Special Characters, but used like the followings that file system allows.


When the song names or artist name included them, I had the error.

Actually, I found similar errors on one Japanese blog with a different set-up.

Then try to avoid these characters on at least one album/track to find out if indeed these are the source of the issue.

I didn’t change the music files characters, but it was a real issue that I face. I tried many cases that music files that only music song name includes those characters, only artist name includes those characters, and every cases had issues.

Over the weekend, I tried another configurations. I changed the setting of Roon core language from English to Japanese on the MacBookPro with music files on QNAP (removed the Synology database setting), then connect the Synology and change the music files location from QNAP to Synology and refresh the database. I don’t know the reason but it works fine this time.

Now I resolved the issue, but I couldn’t get the root cause yet, then hope I will not face the same issue going forward.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.