Error retrieving account information after upgrade to 1.7

Core Machine (Operating system/System info/Roon build number)

Asus B450m/AMD Ryzen 2700 with AudioLinux OS/Roon Server 1.7 build 500

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Xfinity cable modem into Eero router. Server connected directly to router via Ethernet. External Startech HDD drive connected to server via USB.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Server is connected to Intel NUC endpoint running Roon Bridge version 1.0 build 169 which is contested via USB to Soekris 1321 DAC. Server and endpoint are connected over WiFi

Description Of Issue

System was working fine. I upgraded the core to version 1.7, waited for the database to reload and tried to play music using my iPad Roon remote. I got an error saying “ playback was interrupted because a track failed to load”, then when I checked my account it said “error retrieving account information”.

Hi @Colin_Reilly,

Can you try giving your Core a reboot? Is there any change after doing so? If not, can you share a screenshot of the error you’re seeing?

I’ve tried rebooting several times with no success. If I try to logout from the remote it can’t see my credentials. I created another core on my laptop and it sees my credentials just fine and I am able to play music, but I cannot play it from the server core. I am unable to provide screenshots since I am now getting the “are you online” message when I try to reconnect to my server core.


Hi @Colin_Reilly,

Can you share a screenshot of the message you’re seeing when you try to connect to the Core?

Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link.

Here is the dropbox link and the screenshot

Clicking on connect to log in to my server core prompts me to log in. When I do I see the screen below. PC472 is my laptop, not the server core. Clicking on unauthorize does nothing, I guess because the server core isn’t active.

Hi @Colin_Reilly,

Apologies for the delay here. We are hoping we can try with a completely fresh database so we can see if the same behavior occurs. Please see the following steps:

  • Stop RoonServer on the Core
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer on the Core

Hi @dylan ,

Thanks. I’ll do this at the beginning of the week as I’m out of town this weekend, and get back to you with the results.


1 Like

Hi @dylan

I followed the steps above and created a fresh database, but same issue. When I try to connect to my server it takes me to a login page. After logging in I am taken to the authorization page, where I am unable to unauthorize PC472, which is my laptop, not my server. Pressing unauthorize does nothing. What I am trying to log into is in the second screenshot.

Hi @Colin_Reilly — Do you have another machine that you could temporarily install Roon on and use it as your Core? When you do so are you able to log in from that machine?

Hi @dylan,

Yes, I already installed the core on another machine and it works perfectly. See my comments in the posts above about that.

Today I deleted the software from my server and reinstalled it, then reinstalled RoonServer. I got the same issue. The install went perfectly, but it seems it’s an authentication issue on that machine only. Version 1.6 was fine.


Thanks for confirming, @Colin_Reilly.

On the new Core machine that you’re logged into, can you try going to Settings > Account and completely logging out of that machine? Once you’ve done so can you try connecting to the original Core again? Does that allow you to log in?

Hi @dylan

I tried that already and it doesn’t work. I log out, then go back to the server core and try to connect. It asks me to log in, then takes me to the page where it says “are you online?”, then gives me the option to unauthorize the PC core machine. When I click on “unauthorize” it doesn’t work.


Thanks, @Colin_Reilly.

Next, I’m hoping you could use the directions found here and send us over a set of logs using a shared Dropbox link or any other file sharing link. Once we have the logs I’ll get it to the team for analysis.

Hi @dylan

Before I send the logs, is it possible that there could be an issue with the IP address of my server? It is set for DHCP, so it frequently changes. Might the old address be cached somewhere? Right now it’s telling me I have no authorizations.


Hi @dylan

Here are the logs. I downloaded a new version of Roon this morning.


Hi @dylan

Issue resolved. My router was issuing /22 via DHCP instead of the /23 configured in my server network config file. Changing that fixed the problem. Thanks for your help.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.