Error: Tidal media is loading slowly

Hi @support,

Roon is reporting “Tidal media is loading slowly” error frequently in my setup.
It seems to be intermittent and affect major portion of TIDAL library.

Music frequently plays for 15secs and then stops, music skips to next song on the playlist and this goes on and on. sometimes i get the system playing for 30mins or longer, but if i skip a track, same story…

Playing local tracks on Roon is ok and also Tidal library from TIDAL app. Also some friends say they can listen to their tidal accounts just fine from Roon or other means.

My setup:
Mac Mini running Roon Server
T+A DAC8 DSD connected to this machine directly via USB

Can you help with the issue?

Hello @jonnie,

Thanks for contacting support. Can you please confirm for me if the same behavior occurs for all of your endpoints or just the T+A DAC? Even trying with “System Output” will give us a good data point.

How is your Core connected to the network here? Is it connected over WiFi or Ethernet? If it is on WiFi, do you experience the same issue if you temporarily connect it via Ethernet to your Router?

In the past we have seen improvements with users changing their router’s DNS servers to Google DNS or Cloudflare. Can you please give that a try and let me know if it changes anything?


Hi Noris,

Tks for the reply

Did not try to play to system output, but i do know that playing local files through the T+A DAC works fine.

Core (Mac Mini) is running Roon Server connected via ethernet to a TP link switch, that in turn is connected to my ISP Router (a Huawei ONT/Router). This has been working fine for months now.
I also did an internet speedtest with >200Mb/s result.
i normally have Wifi interface turned of.

I changed my Mac Mini Ethernet’s DNS settings to / google public DNS but no improvement on this behaviour.

Additionally i will try to summarize what i see in the logs:

Starts playing
Changed: Ready => Playing

Buffer fills in
DSD128] [46% buf]
DSD128] [24% buf]
DSD128] [8% buf]

But then, several messages state:
Debug: [prebuffer] sleeping in read – this isn’t good

Until it shows several:

And finally
Too many dropouts (>3s dropped out in the last 30s). Killing stream
too many dropouts. stopping stream
dvance didn’t change the track. returning short read
Track Stopped Due to Slow Media
All streams were disposed

It seems to be a tidal track loading issue. But when i play through TIDAL app it works just fine.


Hello @jonnie

Thanks for letting me know that info. Can you please give “System Output” or another endpoint a try to verify if this issue affects only the T+A DAC or all of your endpoints?

Also just to be clear here - It says 46% buf then 24% buf then 8% buf in that order? That would indicate that your buffer is not filling and this issue is due to the buffering of the track.

You seem to be upsampling to DSD128 as well, can you please let me know what your Processing Speed is in the Signal Path? Does the stream with no DSP applied play back as expected? Please let me know this info.


Hi @noris,

Tks for you reply

It did not affect, although i am glad to report that i am being able to play music without interruptions for the intire day now.

Order was correct… it is as if music was initially buffered but while being played remaining file was not being delivered to buffer to be played and thus buffer content being consumed until reaching 0%.
I would say TIDAL apis used by roon were not delivering file content with enough speed as necessary by roon to play without dropouts…

Processing speed is typically 2.7x. I did try to turn off all DSP functions as i initially suspected that busy processor was to blame, but dropouts were still occuring with those functions off.

Tks again for your support, and hope it does not happen again.

Thanks for letting me know @jonnie. If this issue occurs again, please make a note of the exact local time that it occurs at (ex. 6:11PM) and let me know. I can then enable diagnostics mode for your account if needed but hopefully it was just a temporary hiccup.


1 Like

Hi @noris, this issue has been occurring again recurrently.
E.g.: today 22 Dec, 11:24 and 11:38 Lisbon GMT
Tracks take a lot of time to start, and then stop in the middle with the following error:

“TIDAL: Tidal media is loading slowly. This may indicate a networking or connectivity problem.”

PS: Same happens with all DSP off and with system output


Hey @jonnie,

Thanks for letting me know those timestamps. Can I please ask you to try a TIDAL cache clear to see if that helps resolve this issue? Is there any change at all if you log out of TIDAL and log back in?


Hi @noris,
I tried the following:

  • Cache clear
  • Log out/log in
  • Other player (Audirvana)

…problem persists, so it does not seem to be Roon related.

So we are left with:

  • TIDAL API / My Account issue (i have a shared account with 3 more friends - they are ok)
  • My ISP (other friends have same ISP - Vodafone and they are ok)
  • My home network setup (Ethernet or Wifi has same problems, DNS is set to google DNS)

I think it might be my network setup… just not sure how to troubleshoot this…

This is the only networking equipment in use? No access points, mesh networks, hardware firewalls, etc?

I believe @noris has a ticket open on this, and we can have the QA team take another look at the logs when everyone is back after the holiday.

Sorry for the trouble here @jonnie!

Hi @mike,

Just a Router/ONT and a non managed TPLink switch

No problem! Appreciate your help

Hello @jonnie,

I have just received some feedback from the QA team and they did indeed make the same conclusion that this issue is networking related. Let’s try something a bit differently here, does the issue still occur if you bypass that switch and connect your Core directly to the router via Ethernet? Please let me know when possible.


Hi @noris,

I also initially suspected switch could be the culprit, so i made some tests via wifi with ethernet connection disabled on mac mini. Problem was consistent.
I also tried reseting switch and router without luck at that time.
Something to note also is that i had used switch for months and never had a problem.

I strongly suspect from TIDAL services problems, so I opened a ticket on TIDAL support.
This issue does not occur for about 4 days though.

Thanks for letting us know @jonnie,

Since you have performed those tests I am inclined to believe it may have been an intermittent issue with your ISP or your connection TIDAL servers as you mentioned. If it occurs again, please provide timestamps as before.