Error: Transport failure to initialize endpoint device

Hi,

Does anyone know what I can do to resolve this error.
I have used the PIPO X8 as a ROON Remote previously but after recent change in system and update to 1.3 I cannot get it to work.
If I plug a laptop via usb it will work but the PIPO via USB refuses.
I can get the PIPO to play music through any website or application but just not ROON.

Not sure why this is the case.
Re installed everything a few times but no use.

Just to clarify, you are using the PiPO as a player so control plus connection to your DAC? That is how I use my X9S. It is possible RAAT cannot get through your firewall after the change to 1.3. That is where I would start assuming you are running 1.3 on the X8.

Iam using the PIPO as remote, I tried the firewall exception also disabled it completely but same error.

The OP talks about the PiPO via USB. It should be used as a remote via WiFi or Ethernet as far as I am aware.

I’am the OP, issue with multiple accounts.

So yes I use my mobile as a device to control but PIPO is connected to DAC.

Ok, that clarifies matters. My PiPO did not update automatically. I had to reload Roon from the website at which point it did what it was supposed to. Launch Roon on the PiPO and check to see what build is installed using settings and ‘about’. If it isn’t build 200 reload it from the website, not from previous downloads.

I downloaded and installed from the website, used the common full 32 bit installer.

I had the same error with my surface today but a quick reboot fixed it
Not sure why I’am getting this error with the PIPO and most importantly its refusing to play.

Error is:

playback_error_endpoint_device_init_failed

Any ideas???

Hi @alice ---- Thank you for the report and my apologies for the troubles here. This error message you are receiving indicates that the Roon is struggling to establish a “hand shake” with the DAC. May I kindly ask you to please verify the following for me:

  1. You mentioned:

“… but after recent change in system and update to 1.3 I cannot get it to work.”

Can you please provide some insight in to what recent changes have been made to the system.

  1. Please identify the make and model of the DAC being used and can you confirm that other applications can play successfully through this device?

  2. Have you tried power cycling your equipment yet?

-Eric

3 posts were split to a new topic: “failue to initialize device” with ASIO

The issue has now been fixed.
I reset Windows 10 and the problem is gone.

1 Like

Thank you for the follow up @alice, glad to hear you were able to sort this out. Happy listening!

-Eric