Error updating Roon Bridge [Ticket In]

Core Machine (Operating system/System info/Roon build number)

Roon ROCK - Intel NUCi5

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ubiquiti UNIFI

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Digione Signature Rpi 3B running Roipeee connected wireless to network.

Description Of Issue

I get the following error message when trying to look for update to Ropiee.

Ropieee needs an additional reboot with the latest update. That should clear the message.

Edit: I note that the message “You have the latest version installed.” persists for a while and then is replaced with “There was an error checking for an update.”

Running Ropieee 2.486 stable and Roon Bridge B170.

Hi Martin. No luck for me. I have restarted it 4 times now.

That doesn’t seem to be the case. There was no update to RoonBridge (which might or might not have required rebooting the endpoint).

Instead, there is a problem with the Update Server:

05/10 17:28:41 Trace: [appupdater] initial check for updates
05/10 17:28:41 Debug: [base/updater] Checking for updates:
05/10 17:28:41 Trace: [rnet/RnetJsonServer] [client] SENT NONFINAL {"status":"Changed","updates":{"is_supported":true,"status":"Chec
king","progress":null,"current_version":{"machine_value":100000171,"branch":"stable","display_value":"1.0 (build 171) stable"},"available_version":null
05/10 17:28:41 Debug: [appupdater] Update failed
05/10 17:28:41 Warn: [appupdater] Couldn't connect to update server: System.Net.WebException: Error: ConnectFailure (TLS Support not available.) ---> S
ystem.NotSupportedException: TLS Support not available. ---> System.NotSupportedException: No such TLS Provider: `btls'.
  at Mono.Net.Security.MonoTlsProviderFactory.LookupProviderType (System.String name, System.Boolean throwOnError) [0x00032] in <b184df7fd7654b5abda93b
  at Mono.Net.Security.MonoTlsProviderFactory.LookupProvider (System.String name, System.Boolean throwOnError) [0x00000] in <b184df7fd7654b5abda93ba34c
  at Mono.Net.Security.MonoTlsProviderFactory.TryDynamicLoad () [0x00019] in <b184df7fd7654b5abda93ba34c7d29e0>:0
  at Mono.Net.Security.MonoTlsProviderFactory.CreateDefaultProviderImpl () [0x00000] in <b184df7fd7654b5abda93ba34c7d29e0>:0
  at Mono.Net.Security.MonoTlsProviderFactory.InitializeInternal () [0x0001a] in <b184df7fd7654b5abda93ba34c7d29e0>:0
   --- End of inner exception stack trace ---
  at Mono.Net.Security.MonoTlsProviderFactory.InitializeInternal () [0x0002e] in <b184df7fd7654b5abda93ba34c7d29e0>:0
  at Mono.Net.Security.MonoTlsProviderFactory.GetProviderInternal () [0x00010] in <b184df7fd7654b5abda93ba34c7d29e0>:0
  at Mono.Net.Security.MonoTlsStream..ctor (System.Net.HttpWebRequest request, System.Net.Sockets.NetworkStream networkStream) [0x00027] in <b184df7fd7654b5abda93ba34c7d29e0>:0
  at System.Net.WebConnection.CreateStream (System.Net.HttpWebRequest request) [0x00066] in <b184df7fd7654b5abda93ba34c7d29e0>:0
   --- End of inner exception stack trace ---
  at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00058] in <b184df7fd7654b5abda93ba34c7d29e0>:0
  at System.Net.HttpWebRequest.GetResponse () [0x0000e] in <b184df7fd7654b5abda93ba34c7d29e0>:0
  at Sooloos.Updater+WebUpdate.Load (System.String updateurl) [0x00028] in <45ecdb513d4c44c0ba00307524e7086a>:0
  at Sooloos.Updater+WebUpdate.CheckForUpdate (System.String serial, System.String userid, System.String product, System.String branding, System.String desired_branch, Sooloos.Version version, Sooloos.Updater+WebUpdate& update) [0x000a7] in <45ecdb513d4c44c0ba00307524e7086a>:0
  at Sooloos.Updater+<>c__DisplayClass26_0.<ScanOnce>b__0 (System.Object <p0>) [0x0002a] in <45ecdb513d4c44c0ba00307524e7086a>:0
05/10 17:28:41 Trace: [rnet/RnetJsonServer] [client] SENT NONFINAL {"status":"Changed","updates":{"is_supported":true,"status":"Error","progress":null,"current_version":{"machine_value":100000171,"branch":"stable","display_value":"1.0 (build 171) stable"},"available_version":null,"update_mode":"AutoCompatible"}}

Hi this is the exact same problem I reported a day ago here: RoonBridge update error
I tried this with roopieee, volumio and a freshly setup Raspbian installation with RoonBridge installed manually. All show the same error being not able to access the update server due to the TLS issue.

05/09 23:49:16 Warn: [appupdater] Couldn’t connect to update server: System.Net.WebException: Error: ConnectFailure (TLS Support not available.) —> System.NotSupportedException: TLS Support not available. —> System.NotSupportedException: No such TLS Provider: `btls’.

Update: My device running RoonBridge is connected via Ethernet cable. No WiFi involved. But the same TLS error occurs as well.

1 Like

Hi @Jonathan_Magnussen,

Build 171 is the latest version of RoonBridge at this time, but we can certainly gather some more information regarding this issue, can you please let me know:

  1. What is the model/manufacturer of your networking gear?

  2. Can you please provide a full set of your RoonBridge logs via Dropbox / Google Drive / Your preferred upload service?

  3. Are you using any firewalls which could be impacting RoonBridge from connecting to our update servers?

  4. Are you experiencing any issues with this zone or is the update message the only problem?

  5. Is there any change in behavior if you reboot your Roon Bridge?

Hi @noris,

Sounds good - did not expect there to be a new build.

  1. I have a router from Ubiquiti (Unifi)

  2. - the device is called Digione Stue

  3. I don´t think I have a firewall on my outbound traffic. I have a PiHole wich I have tried to disable with no luck.

  4. I have experienced dropouts today - music drops out, then stops. I can then start it again. Haven´t had that before. Not sure they are related though.

  5. I have tried to reboot it more than 5 times with no luck :slight_smile:

I hope you are able to see something from the log files - otherwise let me know.

1 Like

Hi @Jonathan_Magnussen,

Thanks for the information, let me get this over to the QA team for closer review.
Appreciate the report, if any other questions come up, I’ll be sure to let you know.

1 Like

Hello All,

I wanted to touch base with some good news, which is that our technical team has been able to reproduce this behavior and we’ve opened up a bug report with our developers.

While I can’t say for certain when this bug will be fixed, getting things reproduced in-house is a critical first step, and I will keep this thread up to date as the team passes along feedback and work begins to get this resolved.

Thanks again for the report!

1 Like

I am glad that this is being worked on. I came here to report exactly the same problem. Also a bridge on a RPi 3B+.

I’d like to add a question. Since I got this update error I wondered what was the current/latest version of the bridge. I could not find this information anywhere. It’s not on or, it’s not in the release notes, at least not in the latest release notes.

Could you please add this information somewhere? Maybe you could mention the latest version numbers for all packages in all release notes even if they didn’t change?

Hi @G_P,

Yes, this issue is being worked on. The latest version of Roon Bridge is build 171 for most platforms and build 172 (Windows only), this is mentioned in our 1.7 release notes:

I’ll pass this feedback on to the product team.

1 Like

Cool! Seems to be fixed.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.