Error when trying to add network share

I have a Nucleus on my home ethernet network. I have all of my music on a large RAID drive connected to an old MacPro via Thunderbolt. I had a catastrophic failure of that drive a few days ago but, fortunately have another RAID drive that everything is duplicated on to. I had the Nucleus watching a variety of folders on the external RAID drive connected to the MacPro via network shares (iTunes, Qobuz purchases, ripped CD’s). Obviously those are all broken now due to the drive failure and I have to recreate them for the new drive. I am also now getting back-up failures as that folder was also located on the external drive.

Every time i have tried that running Roon on my MacPro (as before), I get the “There was an unexpected error” message. Have worked my way through all of the related support docs on this site and still can’t get it to work. (rechecked the file sharing window and added the drive and the folder, ran terminal command for full disk access for smbd, etc). The system worked just fine a few days earlier with the previous drive. I think the system did update to Monterey a few days ago.

MacPro is running MacOS: 12.2.1

Screenshot of failed attempt follows:

Any help would be appreciated.

try typing

Thanks for the reply and suggestion, Tor. I did what you suggested and got the same error message.


You need to ensure that you have correct username and password as well. I added the example above, worked fine.

Please note that you need to add share; not including all folders within the share :slight_smile:



Then click share (last picture in post above) and navigate to correct folder, and click “Select this folder”.

That still doesn’t work. I tried both with and without the proper user/password.

For the local drive on my macPro, I can successfully use the Browse function and the add network share function. This seems to break down when I try the same on my external drive. Just to make sure, I went to the System preferences folder and turned off and on, all of the file sharing options. Still no luck.

Hello, bought a Nucleus and Roon can’t see my CocktailAudio X50, always the same answer: Invalid pathway, the problem began after the last update…

Hey @Dana_Barnard,

We’re sorry to see that you had issue connecting your backup music library after your RAID failure. In checking your system diagnostics it looks like you were able to get that remedied.
I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.