Etcher not working for ROCK install

I’m trying to install Rock onto a NUC but can’t flash the code to the USB drive. I installed Etcher on my Windows 10 PC (latest version) and Etcher launches with a blank grey screen and does not respond to clicks. Is there an alternative to Etcher?

I used Rufus

Just about to try that. Thanks.

Rufus worked for me. Roon should probably change the kb article to specify Rufus instead of Etcher for Windows 10 users.


in that case it probably isn’t installed properly or something in WIN10 is blocking it. Sounds like a graphics problem though, can you launch in compatibility mode?

Etcher works fine with my Win10 setup - latest version (pro) and basic intel HD graphics 4600.
Perhaps it is the graphics setup that is causing a problem?

Could be, but I tried every compatibility option to no avail. I do have a rather complex graphics setup with three monitors, but I haven’t had issues like this with any other program I’ve used lately.

Rufus worked great though.

Glad to hear the alternative worked.