Ethernet connection problem Roon and "Roon ready" Mytek Manhattan ii

Roon Core Machine

Nucleus +/linux
Mytek Manhattan ii with “roon ready” network chart

Networking Gear & Setup Details

ethernet network

Connected Audio Devices

Analog connection to preamp
Nucleus+ ethernet
Manhattan ii with Roon ready network chart

Number of Tracks in Library

Using Roon only with Tidal

Description of Issue

Roon does not enable the Roon ready Mytek Manhattan ii dac with a message that the manufacturer has not yet completed certification for this device:

Hi Wouter-Jan,
Was this dac recognized earlier and was it ‘thrown out’, or is this machine new to you? In that case, have you installed the latest firmware for the Manhattan?
I have no experience with this dac, but it should be Roon Ready, so this is the only thing I can think of.

Hi Arlan,

It worked properly in the past. May be I need a firmware update. I will check that.

Hey @Wouter_Jan_Veenis, so sorry for the delay in getting back to you!

I wanted to check in and see if you were able to complete a firmware update? Did this help to fix the error that you’re receiving in Roon?

I’d be happy to help if this is still occurring, just let me know :pray:t3:

Update firmware Mytek manhattan ii solved the problem.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.