Ethernet Disable Issue

Hi. I’m still in the trial period and I did try to research this before posting. When using Roon, it will after a few songs disable my Ethernet card. I found this out because it would eventually stop having access to my NAS. After that Roon becomes unresponsive along with the entire PC and I can’t enable the network card. I have to force shutdown the PC and restart it to get everything working again. I tried other programs and can’t replicate the problem even hours after having them open, so it is something with Roon that is causing it.

The PC is a Dell Inspiron with Windows 10 and ssd and I am only using it for Roon and nothing else. I was considering replacing the Ethernet card because maybe that is the fault but wanted to post here first. Thanks.

I run my Core on a machine with a four port Ethernet card without any problems.

Tagging @support. If you really mean card, rather than port, they’ll probably ask what card you are using.

I’m moving this post to the support section.

I don’t know the brand of the card but it is 10 years old and came with the Dell. I did order a new card from TCP in case it needed replacement

Ten year old machines probably aren’t the best candidates to run Roon Core on.

Are there drivers that might need to be updated?

Everything is updated. New audio/video card, ssd, 8gb ram, i5 core processor. The hardware is fine and plenty of processing power for a Roon dedicated machine. This is something with Roons interaction with the Ethernet card.

I tried other services without issue.

I ran my Roon trial on a new Dell Inspiron XPS 15 and started with WIFI. When that didn’t work so well, I purchased an ethernet dongle that plugged into a USB port on the Dell. That worked for me until I purchased a Roon Nucleus.

1 Like

@Jarrod_Cohen, how are you establishing that the ethernet card is disabled, just because it drops the NAS session? If you’re streaming from a NAS to a renderer, you’re asking a little more than loading a webpage. Do you have another PC you can try the Core on? USB/ethernet adapters are quite cheap.

When roon says it can’t play a file after troubleshooting it comes up that Ethernet adapter was disconnected. Then nothing Ethernet dependent works - no websites, etc. My marantz, HEOS devices, Cambridge azur and music apps via phones don’t have any issue while trying to access the NAS.

This only happens when running Roon.

Hi @Jarrod_Cohen,

This doesn’t sound like typical behavior here, can you please send me a copy of your Roon logs by using these instructions right after the issue occurs?

This is a good idea, a USB to Ethernet adapter should be helpful in narrowing down if the issue only occurs on that card.

I’ll get the log over in the morning. Thank you again for your help

1 Like

Hi Noris,

I sent you a direct message with my one drive link and the zip files.

Jarrod c

Hi Jarrod,

Have you tried downloading a large file from the internet using this “suspect” ethernet adapter?
Roon is transferring quite a lot of data when you play, if you browse using a web browser the traffic over the adapter is much lower, what you could try is going to youtube, select an HD video and playback 30 minutes from a browser, is then the connectivity maintained?


I haven’t tried playing of video from the internet but I’ve tried other streamers without issue. I tested them using the same files Roon got hung up on without issue all via Ethernet.

I’ve also had no issue downloading any programs or files of any size to the pc in use.

I just tried streaming 4k YouTube videos at 15 minutes at a time and the ran fine without any lag or disruption.

Ok, let’s see what Roon sees on the logs.
Was worth a try.

I haven’t heard or seen any responses. Is there anyone in Roon support that can help before my trial ends? I’d like to consider Roon but can’t if it won’t work for me. Thanks !

Since you are having problems, @accounts will probably extend your trial should you ask.

Good idea and thanks for the suggestion. I sent them a mesage

  1. I assume you verified that you have the latest ethernet device drivers.

  2. Since Windows is throwing the error, have you checked out the Windows logs and reviewed the Windows error code, if there is one?

  3. Have you tried an alternate Ethernet device like the USB ethernet dongle that has been suggested?

  4. Try moving music to the Dell and playing that and see if the Ethernet acts up playing only music local to the Dell.

You are streaming music data from the NAS to the Dell Core, then what? Is the DAC connected to the Dell or are you sending the stream back out to an endpoint, or having the Dell use its internal speakers?

See my answers below - thanks

  1. Yes, I have the latest drivers
  2. I haven’t checked windows’ error logs, but this issue only happens when using Roon. Using any other programs doesn’t cause an issue. I sent a copy of the Roon log to tech support
  3. I ordered a new Ethernet card and received it today but haven’t gotten to install it yet
  4. I’ve successfully played the same files via Jriver and Audirvana without issue. I’ve also tested leaving Audirvana open for 3 days, and it didn’t drop once and I was able to remote access without issue. I was successful with doing the same for Jriver. I also streamed 4k videos for 15 minutes without interruption to test bandwidth

The hdmi out of my dell is going directly to my Marantz 8805.