Every 20 to 30 Minutes Roon is losing connection

NAS: PC (Windows 10 Pro 64Bit, 40TB, GiBy GA-Z170X-UD3, Intel Core i7-6700K,
Tablet: Mirosoft Surface Pro 4 (1TB, 16 GB RAM, Intel Core i7e)
Merging+Nadac & Merging+Power (New Firmware + new Ravenna Asio Firmware)
NAS to Nadac via LAN with internal IP address, only for these 2 devices.
Roon remote on Tablet (Tablet with virtual screen of PC/NAS!).
Every 20-30 Minutes loosing connection for 5-10 seconds and then it starts to work again.
I have to press the play button again to continue…
Please help!
Regards, Son

PS: Tablet communicates with PC/NAS via WLAN (excellent connection!) of the home Network (different IP-addresses to connection between Nadac and NAS!)

Hi @Thanh-Son_Dr_Wagner,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this behavior occur for all endpoints? If you try playing to System Output of the Core machine do you experience these stops?

Hi Dylan,

Both Nadac and NAS/PC have extra IP-addresses for working together and they are not connected with the home Network (attached 2 pictures of their configurations). I only hear the music from the NAS without streaming from the internet!

For using WLAN between Tablet (Roon control apps!) and NAS/PC I have added the AVM FRITZ!WLAN Stick AC 860 (866 MBit/s (5 GHz), 300 MBit/s, WLAN N, 2,4 GHz, WPA2) to the NAS/PC. Tablet and PC get their IP addresses from the home Network.

I just did a test: adding screen, keyboard and mouse to the NAS (PC: Windows 10 Pro 64Bit, 40TB, GiBy GA-Z170X-UD3, Intel Core i7-6700K, Firewall is disabled) and running the Nadac/PC system without WLAN but the problem of loosing connection stil remains! Nadac is connected with the NAS/PC via LAN cable.

So the cause can not be due to WLAN/Home Network!

I also already have reinstalled Roon Core…

Problems of the software or it is due to the settings on Roon and Nadac???

Please advice!
Regards, Son.

Hi @Thanh-Son_Dr_Wagner,

When performing this test, did you try playing to System Output of the Core machine? It would be good to know if this behavior occurs when playing to somewhere besides the Nadac so we can further narrow down where this behavior is stemming from.

Can you clarify exactly what happens when you lose connection? Is it just that playback stops and you have to hit play again? Does the Nadac completely disappear from Roon? Do remotes disconnect?

Hello Dylan,
Playback system:

  1. NAS / PC with WLAN connection to home network via USB AVM FRITZ!WLAN Stick AC 860, Surface Microsoft Surface Pro 4 Tablet with Roon Control App. Both have IP addresses (192.168.178. xx).
  2. NAS / PC is connected to Merging + Nadac via LAN cable, both have IP addresses (192.168.177.xx)

When the music stops playing, Roon’s on-screen usage display on the remote disappears. It indicated Roon was disconnected and tried to reconnect. About 3 seconds later, the user interface reappears in the pause state. By clicking on the Play button, the music will continue to play! Also on the side of the Nadac device the connection to the PC / NAS was interrupted for a short time like on the display of the control app.

It’s a sign that Roon Core is momentarily interrupted and re-uploaded after a few seconds.
The breaks vary between 15 and 30 minutes, and that is permanent !!!

I’ve heard that Roon Software is constantly luring into Internet to get the license it has obtained. If Roon Core is not on the net, then it will briefly down and start up again in the unsuccessful query!
My PC / NAS, however, is connected via Wi-Fi to the home network with Internet when I hear music … From the point of view, I do not understand the problem!

I still have an OPPO UDP-205 connected to the home network. I’ll let him play on Roon and see if these interruptions are taking place at the OPPO. I will make a report!

Thank you and regards,

Hello Dylan,
I now connected the NAS/PC via WLAN (with USB AVM FRITZ!WLAN Stick AC 860) to the home Network and choiced the OPPO UDP-205 (which is connected to the network via Ethernet cable) as System Output in the Roon App for playing music.
Unfortunately it happened the same way as with the Nadac: after 15 minutes the Roon connection was aborted and raised again after a few seconds!
Do you have any idea?
Thank you and regards,

Hi @Thanh-Son_Dr_Wagner,

Can you try connecting your Core to the network via Ethernet? As mentioned in our Networking Guide, we always recommend this whenever possible. Based on the symptoms it sounds like there are some networking difficulties at play, so this would be a great test.

I now connected the PC/NAS/Roon Core via Ethernet wire to the home network directly. The PC/NAS has 2 Ethernet Wires: one Ethernet wire to the Nadac (192.168.177.xx) and one to the home network (192.168.178. xx).
But the interruption problem still exists!!!
A friend of mine is an IT specialist, he was here and checked all the connections. Everything is connected correctly!
The error must be on the side of the software!
Can you forward me to one of your program developers?
Slowly I am frustrated !!!
By the way I own the Lifetime Membership.
Thank you

Hi @Thanh-Son_Dr_Wagner,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

11.03.2018 / Central European Time:

19:29 Play / 19:58 losing connection
19:59 Play / 20:28 losing connection
20:29 Play / 20:49 losing connection
20:50 Play / 21:12 losing connection
21:13 Play / 21:27 losing connection
21:32 Play again…

Thank you! Son

21:54 losing connction again…

Thanks @Thanh-Son_Dr_Wagner,

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hi @Thanh-Son_Dr_Wagner,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link. We will need logs from your Core machine.

Hello Dylan,
Last Wednesday, I again completely uninstalled the Roon server and reinstalled it (without installing back up!). Since two days Roon Core does not loose connection anymore and it remains stable.
If it stays that way, then the problem is solved, otherwise I will send you the logs as required!
Thank you very much for your service and best regards, Son.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.