Exclusive mode : roon is not working when disabled (2)

Core Machine (Operating system/System info/Roon build number)
Windows 10, latest version.

Ethernet (cable)

TEXT GOES HERE

Windows 10, latest version of Roon as well using a ASUS Xonar U7 MkII sound card.

**** Description of the issue ****

To be clear: exclusive mode IS working (there are several other topics on that matter).
It is when I DISABLE “Exclusive mode”, that roon player cannot play anymore.

Context: ASUS Xonar U7 MkII, on WIndows 10

The exact behavior is the following:

  • music is working properly in exclusive mode
  • I disable exclusive mode in the setting of my device
  • The current song immediately stop as I save the new settings
  • When I click on ‘Play’ to restart it, roon tries to restart playing but fails to and skip to the next song. As the next song fails also, it goes to the next and so on… until I the playlist is empty or I turn back to exclusive mode.

I know exclusive mode is better, but this is a secondary set up (home office), but there the usage is different from an audiophile listening. I also need to be able to switch from other sound sources (video, communications, game, …) and this is ‘complicated’ when roon is running since I need to stop it completely, restart the browser and the other way around when I need to go back to roon.

I tried via ASIO4ALL, … not working either.

Does anyone have a work around? Thanks !

More details: Here is the entire setup:



image

Do you have an audio device called “System Output” on your PC? If you do (I have this on a Mac) enable it, that would play through the Windows “mixer” - and that’s what you would need if you want to be able to hear output from multiple sources inside the PC.

Yes I do, but I have the same problem…

But it works fine without passing thru the “System output” on the same setup with another DAC as shown below


image

Hello @Yves_ADAM, could you please try to play to system output with exclusive mode off one more time and reply here with a timestamp when you do? I’d like to enable diagnostics for your account and show the results to the team. Thanks!

Also, does system output of a remote work without issue?B

Hello Nuwriy,

I did not see your message last week… if your traces were disabled, I can repeat the test.

I have done the test at 11:05:31 Brussels time:

To clarify, the steps are the following ones:

  1. listen to PinkFloyd without problem in exclusive mode
  2. Disable exclusive mode at 11:05:31
  3. Cannot listen to music anymore
  4. Switch back to exclusive mode, music is back.
    This test occurs on a Windows 10 PC with my external 7.1 sound card from ASUS, the Xonar U7 mkII, It is NOT the Core system.
    On that same PC, I did not have that problem with another DAC (not requiring dedicated driver: TEAC UD H01)

To answer your last question…
First I am not sure to understand what you mean with a ‘remote’ ?
Anyway, to test it on another system than the one experiencing the present issue, before I tested the above I did some tests on my Core system. This one is also housing my main listening system, based on a high end I2S bridge from PinkFaun driving 4 separate DACs (https://www.pinkfaun.com/shop/bridge/69-4072-i2s-bridge.html#/additional_clock_for_bridge-no/bracket_height-79_2_mm_3_118_inch/compatible_i2s_dac_s-please_select_your_dac)

This card uses also the standard Windows driver.
The answer is: yes and no, it depends on the setup, depending on the sound path:

NOT working: Roon > System Out > PinkFaun
Working : Roon > System Out > JRiver > PinkFaun
Working : Roon > PinkFaun exclusive mode
Working : Roon > PinkFaun non-exclusive mode

Hello @Yves_ADAM, I enabled diagnostics again the other day but it seems like they haven’t come in from your core. Could you please reboot the core and open Roon so the report can upload? Thanks!

Done, just now.

Thanks @Yves_ADAM, I got the report and have since sent it over to the team. I’ll return once I have their feedback!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.