ExFat drives aren't accessible from ROCK in case of mounting via SMB [Fixed, B156]

Fully agree
If I connect the had drive to another device, I can have access through my iMac as usual. Problem is evident only when connected to Roon

Also have noticed that song selection, from pressing play to start of play, seems to take far longer than in the past. Anyone notice this? Currently my music disc is locked but the backup usb stick isn’t.



I hope this is the right place.

I run ROCK on NUC with an attached WD USB disk.

I use a MacBook Pro to manage my files.

Although I can see the ROCK share, and connect to it to see the Data folder structure, the Storage folder where I am supposed to see my music files is not reachable. It says:

The folder “KutluayDuo_WD_My_Book_Duo_25F6_575542533238313130333531_59F0-ED48-p2” can’t be opened because you don’t have permission to see its contents.

and the name is funny since from roon setup I simply see KutluayDuo when I am managing the storage selection.

What might be wrong?


Can you try to mount it with cifs://ROCK/Data instead of smb://ROCK/Data and let me know if that makes it work?

Is your MyBookDuo formatted as ExFAT?

1 Like

Hi Danny,

I was having the same issue using my iMac. Using instructions above I got it to work.

  1. Right click on Data and select Eject “Data”
  2. Under Go, select Connect to Server.
  3. In Server Address, type cifs://rock/data
  4. Connect as Guest (if it asks)


Cheers, Greg

Greg, As of late last week, it seemed like using “cifs” was regarded as a workaround until Roon understood what was causing the problem.

Should we cifs users assume that to be a permanent solution? It seems innocuous enough, although someone at Roon suggested that cifs was a bit slower than smb.


PS: FWIW, cifs works fine for me and my EXFAT external drives to my ROCK. No performance issues that I can detect versus smb.

Hey John,

This would be a question for @danny.

Cheers, Greg

nothing has changed since last week… but this workaround is a fine solution.

Hello Danny,

As per my post a bit higher up on this thread, this workaround doesn’t appear to completely solve the issue. the cifs command appeared to work but when then using the second smb as per the comments from Piotr (6 days ago) my main drive is again locked. Also seems that drive access is much slower.

I do think have the same problem with my windows pc:


It works as you suggest. And yes the drive is ExFat

I don’t believe there’s a need to do the second smb command. If you can connect using cifs, leave it at that. That’s what I’ve done, and all works just fine.

Thanks for you reply…thought the second SMB command restored the drive to the faster protocol…not so? Disc access seems slow but I have no measurements to corroborate this.

You’re welcome. The second smb command did not work for me either, but Roon functions without it and I have access to my files. I do agree that response is slightly slower, but nothing I can’t live with until Roon implements a fix.

”…until ROON implements a fix…”. As you say, this isn’t a big problem but hope it is on their radar and planning a fix. .
In my limited experience some of these more minor issues seem to slide down the list with minimal comment from ROON representatives.

Just discovered that I have this problem too. I do not use my Mac to access ROCK external HDDs normally (so no idea when this started) but have just noticed them showing in Finder with the same error message as detailed above and ‘No Entry’ symbols over each drive.

Just updated ROCK Core and ROON to build 300 and the problem re-appears. Both backup drive and music drive have become locked.

After this update ROON cannot not write to the drives using the cifs protocol…so what’s up?

multiple post. Apologies

We’ll take a look Warren, but just to be clear, the changes in Build 300 shouldn’t have any effect on drive mounting in ROCK.

So I understand, you’re not able to mount the drive using CIFS at all anymore, or the mount you previously set up stopped working here?