Explicit songs coming on roon radio with filter enabled

So, I think I see the problem, but am wondering if there’s something I can do to fix it on a per album basis.

I checked the albums that had the random F words and there was no E icon, which tells me the album is not marked as explicit, however, the lyrics still show the F word.

Is there a way for me to manually mark an album as explicit so it won’t play it in the future when I have the explicit filter enabled? I don’t mind hearing F words, but I would prefer to not play them around my kids.

lol nevermind, I found the button on my computer. I didn’t see it on my phone.

Hi SpicyMusic,

There are several management options available on the computer or tablet UI which are not on the phone UI.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.