Explorer 2 not working on Roon

Can you help me set up the Explorer 2 for my 10-day Roon trial? I’ve tried what I think is every possible combination! Many Thanks

Can you let us know what you have Roon on and how you connect to the E2?

I’ve simply got it into my laptop, downloaded at 64! Thanks

Hello @Stuart_Matheson,

Is your device not showing up in Roon at all, or is it showing up and not working? Make sure to check the Settings>Audio screen and click the “Enable” button for the device.


Ah, now I’m not sure I ever saw an Enable button! Do these help:

In your screen shot, you have both Tidal and Roon Open. Each program may try to gain exclusive control. Try closing out both programs, then open just Roon and see if things change.

Message is “Transport: playback has failed due to unexpected error communicating with audio device” Tidal is off now!

Hello @Stuart_Matheson,

I would recommend restarting your computer and device. Tidal has a nasty habit of retaining “rights” to exclusive control of the device in situations where it shouldn’t. If that doesn’t work, open up the “Device Setup” for the Explorer 2, open advanced settings, and turn “Enable Even Driven Mode” to the off position.


Thanks, out tonight, will try tomorrow!

Done, but still not working!

Yet when i turn on Tidal I initially get a message that device is in use in another system- presumably Roon!!

Hello @Stuart_Matheson,

Make sure you have the latest firmware and drivers installed for the Meridian Explorer 2. You can find them here



1 Like