Exporting playlist content causes Roon client crash [Resolved]

Hi @Dylan,

I am also having problems exporting with build 528.

I can export an album but not any playlists or tracks. My core is on a nucleus + and I am sure I was able to do this before this build.

I currently have a different trial license with the core on my MacBook Air. This is also build 528 and has no problems exporting playlists or tracks.

I hope this may be of help in finding the problem.

1 Like

Hi @David_Miles,

What kind of tracks are you trying to export and where are they located? On the Nucleus internal storage? Or do you have the files on some kind of NAS?

Hi @noris,

Thanks for getting back to me. The tracks are all FLAC files and are stored on an internal SSD in the Nucleus +.

The crash is as soon at the first track tries to export as you will see from the attached screenshot.

I hope this is of help.

Hi @David_Miles,

Thanks for the screenshot. According to the screenshot it looks like it’s working?

What do you mean exactly by a “crash”? Does the Roon app close and you get a “Roon quit unexpectedly” message? Can you please clarify on this?

Hi @noris,

Unfortunately, it is not working. The screenshot shows the situation about 5 seconds after pressing the expot button.

It then stays like this for about another 10 seconds after which the Mac beachball appears and the program becomes totally unresponsive. At that stage all I can do is force quit the program. No file is created in the folder selected for the export.

I hope this helps.

Hi @David_Miles,

Can you please reproduce this issue once more and let me know the exact local time + date you try to export the tracks? Once I have this information I can enable diagnostics mode for you account and check to see if perhaps logs have further clues.

Hi @noris,

Have just tried the export again with same result i.e. beachball and program unresponsive almost immediately thereafter.

I pressed the Export button at 18:45 GMT today 17th March 2020.

Should I force quit the program or leave alone for now?

Many thanks for the help.

Hi @David_Miles,

Thanks for letting me know the timestamp. I have gone ahead and activated diagnostics mode for your account and what this action does is automatically upload a log-set to our servers for analysis.

Please force-quit the program and open it once more to ensure that this report comes through, thanks!

Hi @noris,

Have just forced quit and restarted and will leave program on the overview screen.

Hi @David_Miles,

I can confirm that logs have been received and I have passed them on to QA for further analysis. It may take a bit of time to hear back from QA regarding analysis but in the meantime feel free to continue using Roon as you would normally do. Once I have further information I will reach out once more, thanks!

Hi @noris,

Glad the logs arrived OK. Thanks for your help and I await your update in due course.

Hi @David_Miles,

I appreciate your patience until I had a chance to discuss your case with QA.

QA has informed me that this is a known issue, and a ticket has been submitted to the dev team for review regarding this behavior.

I can’t comment on when exactly this behavior will be addressed, but we are aware and working on it. I appreciate your patience until this reaches the front of the dev queue!


Hi @noris,

Many thanks for the information and your prompt response.

1 Like

Core Machine (Operating system/System info/Roon build number)

SonicTransporter i5 Roon 1.7, build 528

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio gear (818v3, SonicTransporter) is wired and isolated on dumb Netgear switch. Rest of network consists of Ubiquiti APs, Switch, etc. For this issue I tried both wired into dumb switch and WiFi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Exporting a playlist hangs Roon remote 1.7, build 528 on both MacOS 10.14.6 (Mojave) and 10.12.6 (Sierra). A playlist with 3 tracks that all play hangs Roon remote (only Force Quit will work) when I try to export it. Tried both wired to dumb switch that has my Roon core on it as well as WiFi.

Also tried rebooting Roon core as well as both MacBooks running Roon remote.

Hi @soundserge,

Thank you for your report. We are aware of this issue and are working on it, please see above:

1 Like

And ??? 5 months … and no solution ?

1 Like

So… It’s been some days now that your QA is “working” on that … It’s getting a little bit frustrating with this problem.

The only solution until now seems to be a complete delete of the library and to start again. But after some time, I now have the same problem again, but still no solution from your side…

Hi everyone,

We met with our team to discuss the current status of this investigation is still with our development team. We’ve upped the priority on this and, while it will not be able to make it into our next release, we are hoping that a release in the near future will include an improvement here. You have our apologies for the ongoing trouble!

1 Like

Roon Labs,

The issue was reported in this thread on March 15, 2020. On March 18 a ticket was opened. The issue/ticket/thread sat for 4 months with no update until another member persisted and got the same response from you, and you “upped the priority”. It is now September 20, a full SIX MONTHS since the issue was reported, since the ticket was opened, and 2 months since you 'upped the priority". What’s the status? Are there any notes in the ticket? Is this being worked on? Do you need to up the priority again?

Hi @DonaldLL,

Thanks for your patience here! I just checked the status of the ticket and I see that it’s actively being worked on.

As per policy, I can’t comment on when the work on the ticket will be fully completed and ready for release, but there have been recent updates, so it is making it’s way through the queue!