Extension not showing for Apple TV Roon Remote App

Roon Core Machine

Windows 10
Apple TV 4K

Networking Gear & Setup Details

Connected Audio Devices

Library Size

Description of Issue

Apple TV Roon Remote app shows Core located and refers me to settings/Extensions in core to authorize extension. No extension showing.

I’m having this same issue - please help.

1 Like

Hi @Brian_Robbins @Michael_Rother , i’m the creator of the ATV app.

It sounds like the app has connected to something if you’re seeing the core located message.
Can I check that the core located name matches that of your Roon core?

I’ve had a similar issue in the past when trying to connect to a core running on a Mac, the following fixed the issues for me:

  • Quit Roon on the Mac.
  • Close the TV:Remote app (double tapped the home button to fully close)
  • Disabled/Enabled the Mac’s wifi
  • Re-launched Roon
  • Re-launched the TV:Remote app
  • The extension was then displayed in Roon

Similar issues in the past have also been port conflict related - Its possible to check the port number being used for extensions by viewing the Web Display URL. From a Roon client view Settings > Displays.

1 Like

Good evening. Although I’m running Windows 10 and your troubleshooting is for a MAC, I followed your instructions, verified the name of the Core to be correct and have not resolved the issue.

@R_102 I’m still unable to see the AppleTV extension in Roon, although AppleTV is recognizing the Core. I’m on Windows 10. Thanks

Hi @Brian_Robbins, i’m suspecting something on the network is preventing the extension from appearing in Roon. The app itself has managed to open a connection to the core so it thinks all is good.

On the Windows 10 machine are you able to temporarily disable any anti-virus / firewalls you have in place?

Thanks @R_102 . I ran through the prior troubleshooting instructions tonight with firewalls disabled. Same issue :weary:

Does the Roon Web Display work when viewed from a browser that isn’t located on the Core?

If that works could you try connecting manually with the IP address and Port number; ATV > Settings > App > TV:Remote.

Is the issue the same when the ATV is connected via Ethernet or WiFi?
Are you able to temporarily run the Roon core on another machine?

@R_102 I don’t have another compatible device to do Roon Display and no other device to operate as a temporary Core.

My main floor AppleTV is WiFi connected and my Theater AppleTVbis Ethernet.

Does connecting manually show the same issue?

If the app is getting to the “Enable extension on Roon” screen then the app has been able to open the API (WebSocket) connection to something. At this point the app is happy and waiting for the enabled response from the core.

Are you able to temporarily simplify your network by connecting the core and ATV directly to the router?

Previous cases of this issues have been network related - usually a port conflict.

@R_102 I’m not sure how to connect manually. The Core and one of the ATVs are connected via Ethernet to the same Netgear switch from the router. The second ATV is connected via WiFi.

To connect manually, on the Apple TV go to: Settings > Apps > TV:Remote. Select connect manually an enter the core ip and port number.

If your unsure on the IP / Port number see: Roon > Settings > Displays. The web Url contains the required IP and Port.

Have you tired connecting both directly to the router?

Does the Win 10 have multiple network interfaces? What happens if you disable the one’s not being used?

I have same issue.
TV:Remote on my ATV find my Roon core. But when go to setting>extension in my Roon core - it does not dispay any extension…
Buth ATV and my Roon core (over windows 10 server) are connected to same router

If I try to connect via Roon core server ip adress - TV:Remote does not find the roon core…

@R_102 has tried helping me but I’m done. Not resolved and I can’t invest anymore time. Good luck.

@Brian_Robbins it might be worth double checking the firewall settings:

@R_102 I disabled the firewall when I performed the previous troubleshooting suggestions. Is there a setting that would block it even with the firewall disabled?

@R_102 Fixed! Embarrassed to admit, the hardwired AppleTV was connected to the Comcast router, not the Mesh and the WiFi connected AppleTV was connected to the Comcast WiFi, not the Mesh that the Core is on. I was certain they were all on the Mesh. :flushed:

1 Like