Extent supported Display list

Hi @spockfish

Will you consider extent to support other size and 3rd party display such like 3.5 inch?
Or give a how-to document to leverage your official 7 inch display support.

The reason is there is a 3.5 inch display can only use GPIO to get power and the vender also provide linux driver. Instead of 7 inch needs HDMI, power cord to works.

you may take a look here: http://www.lcdwiki.com/3.5inch_RPi_Display

The SPI buss is busy on my setup with controlling an ESS dac. That doesn’t mean that I can’t hang extra stuff off the SPI buss, but it might be problematic.

The supported screen uses the rPi display connector which also passes the touches via that connector. I would bet if there are other sizes of displays that leverage that connector they would be easier to get working.

Hi Sheldon

I am not familiar with “rPi display connector”. Would like to tell me how to change it when you have free time?

Take a look at this, the physical installation section shows the ribbon cable and power connection

https://www.raspberrypi.org/documentation/hardware/display/

1 Like

Hi,

There is no support planned for other screens then the official Raspberry Pi touchscreen.

Thanks

Thanks for that link. I bought a 5” 800x480 TFT Raspberry Pi DSI Touchscreen (DFR0550 from DFROBOT) a while ago, but I wasn’t able to make the touchscreen work correctly. The display was OK, but I couldn’t put it in pause, …
Thanks to the URL you pasted, I started to fiddle with the display-settings in /boot/config.txt, and I discovered I simply had to put the entry “lcd_rotate” to “0” instead of “2”. Nothing else helped. But now, my 5” is doing a perfect job.
Of course, this is not supported by RoPieee, so no claims when after an update it is not working anymore!

Would you like tell me.

  1. Its able to display RoPieee UI (album, composer, etc) ?
  2. How you make it works?

I am speaking a bit out of turn here because I don’t know all the details of Harry’s code, but it appears that the DFRobot touchscreen is behaving like the rPi official touchscreen. Touch data and video signals are going over the rPi video connector. So from a software standpoint the rPi really doesn’t know the difference. I’d suspect if that is the case, it will be supported as long as the rPi display is supported. I didn’t realize that other manufacturers were using that connector and not the HDMI.

Sheldon

As Sheldon explains, the 5”-screen DFR0550 from DFRobot is also using the same DSI Display Connector as the official rPi touchscreen. It is NOT connected via HDMI! Also the number of pixels is identical: 800x480.
So I was convinced that it would work with RoPieee without any necessary adaptation. But it turned out otherwise. The touchscreen is reacting inversed, compared to the official rPi 7” touchscreen. If you want to put the music on hold, you don’t have to push on the pause button, but you have to push somewhere in the middle of the top of the album.

To fix that inconvenience behavior, I found out that you have to change the setting “lcd_rotate” from “2” to “0” and reboot RoPieee. The setting is in the file /boot/config.txt . After rebooting RoPieee, also the touchscreen is reacting in a correct way.

So now the 5” screen is reacting exactly like the official 7” screen, but is just a lot smaller (121mm x 65mm) compared with the official 7” screen (193mm x 111mm).

Frank.

I just found out that it is much simpler. You don’t have to logon via SSH.
Just logon in RoPieee via your browser, go to the tab “Display” and change the “Orientation” from “Rotated” to “Default” and everything is fine.
Apparently the DFR0550 is automatically putting the screen in the correct orientation, but only the touchpad is inversed when the RoPieee Display Orientation is in “Rotated”. Nice to know.

Frank.

Got it, good to know that. Thanks you and Sheldon.

Those using 5" displays, are they still working with the new version of Ropieee? If not, what was done to get it working again?

Since one of the last updates, the display have 3 functions: displays what is playing, displays the clock and totally black. You can toggle between those 3 functions by toughing the screen.
According to me, the 5" displays, when it comes in the ‘totally black”-status, it turns of the touch-screen. So you cannot touch it again to go again to the “display what is playing”-status. The only solution is to reboot the RPI.
@spockfish It would be nice if Harry would make it possible to skip the “totally black”-status, so that you can toggle only between “Displays what is playing” and “clock”.
But, as you should know, only the official 7”-display is supported by Ropieee, so problems with the 5”-display is not covered by Ropieee. We can only hope that Harry wants to make this implementation of an extra option to remove the “Totally Black”-screen. Lets wait his reaction.

I may be wrong here, but the totally black screen is even there on the 7" screen. I believe the mode is intentional and Harry programmed that in so users could essentially blank there screen and show nothing. A 4th touch will return the screen to current player selection and the cycle will continue.

I’m testing a 5" screen on my current build, and one thing I’ve noticed is, the transport controls - forward and back - don’t work. That is, where they show up on the screen. However, there is a ‘dark mode’ to get to them. If you touch roughly the middle of the artist line, under the track, about 1.5" inch from the left of the screen, you can pause the track. Touch a little more to the right, and advance the track. To the left, you can go back a track. The buttons are there - still programmed to do what they do - we just can’t see them. They’re ‘covered up’ with the graphics. Weird huh? I’m sure Harry could enlighten us, but as I know, he doesn’t support it. :frowning:

I really want to get a 5" screen working so I can take control of roon from the touch screen. It may be limited, but doable. At the moment, I’m trying to get the Roon Web Controller client up and running. This is my 4th attempt. :frowning: I can’t seem to get the web controller to show up in the extension list. I’m obviously missing an important step. I’ve been following the guide to the letter too. What is not obvious, is whether or not I can use Ropieee while I’m trying to fiddle with getting the extension thingy to work. Maybe I need to just use the roon-bridge instead of Ropieee - even though that’s what’s being invoked with Ropieee (I believe). Once I can get the Web Controller working, that will take over completely, from a RPi web interface and I forget about using the display feature in Ropieee.

Rick

Hi Rick,

I think you will have to correct the settings in RoPieee under “Display”.
The “Orientation” has to be put on “Default” for the 5" display. For the 7"-display the setting has to be on “Rotated”.
Now your action-buttons will work on the correct place.

But what I wanted to explain in my previous message: when I click on the screen the first time, it is going to the “Clock”-display (like with a 7”-display).
When I click again on the screen, it is going to the “Totally Black”-display (like a 7”-display).
But now, when it is on its “Totally Black”-screen, you can tough as much as you want on the 5”-display, but it will never go to normal display anymore. Here the official 7”-display is going to the normal display, and you can continue to swap between those 3 different displays.
I hope this clarified my previous message.
Frank.

Hi Frankf,

I understood it, but my screen seems to cycle through all of the 3 different screens and never froze on the ‘blackout’ one. I will test again today, with the proper screen orientation, and get back. BTW, I’m using an Osoyoo branded 5" LCD from China.

Rick

Hi Frank,

My findings on a separate instance of Ropieee with an attached 5" screen are similar to yours. But I have noticed a slight difference.

For simplicity sake I’m going to refer to the screen having two sections. The left-hand (LH) album art, and the right-hand (RH) transport controls. BTW, my screen’s default setting (not rotated) is working.

  1. The RH controls the transport controls as normal. From the RH side I cannot invoke the clock on a 2nd touch. To invoke the clock you have to 2nd touch anywhere on the LH side. Don’t know if that’s what you found as well. Not sure it matters. :slight_smile:

  2. Once on the clock screen, you can touch anywhere to invoke the ‘blacked’ out screen.

  3. Touching the blacked out screen, returns to the playing now screen. However, as you observed, the controls do not function, and the screen runs through a refresh cycle (about 8sec for me), before returning to the playing now screen with the controls functioning normally on the LH side.

Regardless, for now it works in a qrickery sort of way. Not a show-stopper for me, but wished it worked correctly - like the 7" does. Hopefully, Harry will fix this in a future software update for those users interested in this feature.

Rick

Hi Rick,

The funny thing is that changing the setting of the orientation of the screen in RoPieee makes no difference on the orientation of the screen (it always display correctly). But it changes only the orientation of the touchpath over the screen. This is only the case for 5"-displays.
So I would ask you again to change the orientation-settings in RoPieee and test it again.

Kind regards, Frank.

I had already changed it to ‘default’ earlier. So my transport controls are working correctly in their notmal location until the 1st touch. Then it cycles through the clock and black screen, before rebooting the interface.

Edit: It all seems to be working correctly now.

Rick