Failed Database Updates

(John) #1

My ROCK core has been running perfectly for quite a while w/o any issues, but I just noticed the Roon database update stopped about 3 weeks ago (I have it updating only once a week). Tried to get it back online again, but to no avail. Finally ended up deleting the DB and starting over. My network is pretty simple. A home Windows workgroup with the backup folder being a network share on my personal PC. Couldn’t get Roon to recognize the network share folder in my PC when initially using the exact same path and login information as before. However, no matter which way I tried reconfigure it, No Go. Has Roon recently adopted any special linux to Windows network notation that wasn’t used before? I finally gave up and did a DB backup to Dropbox (though I’m ag’in it :wink:) - curious there too - I have a U-verse 1Gbps Internet connection and it was only 30% done at 30 min; had to leave, so I don’t really know how long it took in the end - and my Roon DB is less than 1GB (well, compressed, maybe 5Gb uncompressed) ! I’ve never used Dropbox before, so I don’t know how unusual a behavior this really is - it doesn’t seem quite right, though, does it? Any ideas?

  • john
(Ged) #2

Have any windows updates happened recently?

(John) #3

A cumulative Windows 10 update is occurring right now, but it looks like it may have been delayed for some reason; it was dated 2019-07.

(Ged) #4

There have been a few people with w10 posting of late with storage access problems.

(John) #5

Interesting. I’ll see what I can google on it. Thanks!

(Ged) #6

@support will be along to help.

(John) #7

Thanks !!! After the latest update installation, I had to re-enable firewall permission for at least several of my programs. Although, this issue with the database backup seemed to occur before the install. EDIT: It just popped up on my PC that Roon and the RAAT server programs were among the those that for which Windows was requesting firewall permissions. But still this issue occurred before that Windows update . . . I’ll have to see what’s cooking now.

(John) #8

Still No Go; guess the update (at least the latest one) may not have been an issue. Maybe it’s something I’m doing, but pretty I’m using exactly the same settings I was using before. Giving up for now, but will try again tomorrow.

(Ged) #9

I presume you can use roon just the backups aren’t working?

(Alfred van Hoorn) #10

Possibly the SMB settings in Windows Settings? See the the installation of the Windows components (I think in the App compartiment of the Windows Settings).

(John) #11

Yes, that’s correct, Roon’s totally functional. It’s just the Roon DB backup (not the music file storage). I changed the SMB settings when I did the original Roon installation, but I’ll have to check again.

(Noris) #13

Hi @da_Choge,

Just to confirm here, you are saying that the location to the Roon Backups (located on your Windows PC) are currently inaccessible? How are you connecting to this share, are you using hostname or IP Address? If you are using Hostname, can you please try giving IP address connection a go? Our Add Folders By Path Guide outlines this type of connection.

(John) #14

Noris:

Yes, I can’t get Roon on ROCK to establish a path to the network share for its DB Backup. It was fine for a whole year before this, but 3 weeks prior to today, the DB backup failed and stopped. I first attempt to re-establish the path, but then just deleted the old backups and started over. I was able to get a backup established with Dropbox, which I haven’t used before. But I haven’t been able to reconnect to my old backup location on my PC, which is part of the network. My PC shows the folder as a network share.
I have been using hostname for my most recent attempts, and in the past when the backup was running. However, yesterday, I used both in multiple attempts to connect, but I’ll try the IP Address connection again today >>> Did so, and still no go. I’m going to fiddle with it some more and will get back to you. Thanks.

Oh, BTW, my PC has a static IP address and I finally changed the ROCK’s IP address to a static one yesterday, thinking that might help, but it didn’t

(John) #15

Noris:

Everything I have done fails. I used the exact same username and passwords I did when I originally successfully established a network share many months ago (almost a year?), but no luck. When I use the IP address, it still fails, but it gives me an answer immediately (took a little longer with the hostname). The answer it always gives me is: “There was an unexpected error: Unexpected Error” in a pink background box. I think I’m just going to be satisfied with the Dropbox backup for now, maybe I’ll try again next week. BTW, should a Dropbox Roon database backup take almost an hour (well over 35 minutes, at least) on a 1Gbps Internet connection for a 5 Gb database (< 1Gb compressed)? - seems like an awful long time for that fast of a connection speed.

(Noris) #16

Hi @da_Choge,

Dropbox backups are usually rate limited by upload speed, you can change this in Dropbox settings (see: https://help.dropbox.com/installs-integrations/sync-uploads/faster-sync).

Since the PC backup share is not accessible, I wonder if perhaps there is a firewall blocking the connection. Just to clarify - are you using the PC as a Roon Remote while connecting to the ROCK or are you accessing ROCK via another Roon Remote such as a iOS/Android device? Can you please double check that Roon.exe and RAATServer.exe are still added as exceptions to your Windows firewall and any other firewalls you may have in place? You can locate these .exe in the Database Location/Application folder path.

(John) #17

Noris:

The PC in my bedroom acts as a Roon endpoint/remote and the Roon ROCK (core-server) is on a NUC in the living room. Of course, they are both attached (ethernet hard-wired) to the same the LAN home network. I am accessing the Roon settings through my bedroom PC. The backup hard drive is on my bedroom PC and it and its subfolder (the network share I’m trying to backup the Roon database into) are both named as network shares and they show up as such in the Network settings of my PC (Windows 10). And, BTW, my PC’s Network sees the ROCK just fine, as well. I had it setup this way since I installed the core in the NUC (the core was originally on the PC I’m referring to), and it was working without issues for months. But the backup failed 3 weeks prior and I have not been able to connect the Network Share (path) to my PC since I started trying several days ago – is there something wrong with this setup? I’ve tried with all the firewalls in my PC shut down and it didn’t help. And, anyway, the Roon.exe and RAATserver.exe programs are listed as programs which are allowed through the PC’s firewall. I may/may not be doing something very basic/obvious, but it’s not obvious to me. I access Roon via an iPad Roon remote when I’m downstairs using my main music setup which is physically located close to the NUC ROCK server/core. I could go down there and try to set the backup through the iPad remote, but it shouldn’t make any difference, should it? EDIT: I did, just for kicks, and it didn’t (make any difference):smile::frowning:
P.S. Thanks for the tip about Dropbox! Tried the backup and it took about 3 minutes!

(John) #18

Noris:

Any further ideas? I have the Dropbox backup, so at least I’m covered there. But the inability to name a Network Share that Roon will accept from my PC bothers me. The Roon program was originally installed on my PC before I had the ROCK NUC; so the Roon core was originally on my PC and then I transferred it to the NUC. Could I do an uninstall on my PC and then reinstall - could that possibly help? It’s been a while since I installed/transferred the Roon programs/apps. Once I uninstall from my PC, do I just do a new install of the Roon APP on my PC and it will serve as an Endpoint as well as a Remote? Will I lose any functionality that I will have to redo settings for? (again, the Core is on a separate Roon ROCk NUC).

(Noris) #19

Hi @da_Choge,

Yes, you can try to perform a reinstall of the Roon Remote app on your PC. Since it is a Roon Remote and not the Core itself, you shouldn’t lose any settings. To ensure that you set the old Roon Remote application aside, I would use the following instructions on your PC:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Verify if the same issue still occurs

I also wonder if perhaps any of your SMB settings were reversed, as it sounds like you are using an SMB conenciton to the remote PC. Please take a look at this article:

Are other shares accepted or is the behavior the same for any share you try to use? What kind of HDD is connected to the remote PC, can you let me know the model/manufacturer?

(John) #20

Noris:

I have enabled SMB1 Client on my Windows 10 PC several times (it is also important to note that there is an option for “SMB1 Automatic removal” [which I finally unchecked] in the Control Panel. I also realize that the Windows’s 10 Creators Update has either removed or disabled the SMB1 Protocol. Despite selecting the SMB1 Client box in the Control Panel, I still can’t create a Network share for the DataBase backup in my PC.

When I go into my PC’s Windows 10 PowerShell and look at the SMB1 and SMB2 statuses, it will always say “true” for SMB2 and “false” for SMB1 no matter what I do in the Control Panel. Further, if I try to enable SMB1 through the PowerShell, it comes back with a response that “this service is not available”. I’m assuming that this is referring to the entire SMB1 Protocol and not just the “Client” aspects of it, but I don’t know.

I could try to create a backup within the NUC Server itself on my SSD music file Storage Disc (the DB and the Roon core is on a separate M.2 SSD in the NUC), but I think that would obviously work, and it’s not where I really want to store a backup, but I’ll give it a shot.

A further question is why isn’t Roon using the SMB2 Protocol and eliminating all these issues with the outdated SMB1 Protocol, or has that already been done?

(Alfred van Hoorn) #21

Did you also try selecting SMB1 Server box in the Control Panel? Your post is not fully clear about that. Installing SMB server protocol seems to me a key factor, but I am not sure.