Failed to boot after installing Roon OS

Configured BIOS, installed Roon OS successfully, connected to network. Turned on NUC and got this message: Failed to boot when flipping back to B. Roon OS and the previous version installed both refuse to boot. You will need to manually run the recovery process using the USB installer. Hit enter to reboot. I then inserted the USB drive with the image and hit enter but I get the same message. BIOS shows my M.2 drive as boot option 1 (Roon OS on this) and USB thumb drive as boot option 2 (install image). I get this same error message whether I am connected to the internet or not, and with or without the USB thumb drive inserted.

Hi William, Did you find a fix for this? I’m trying to setup a NUC too and get the same message.

I reinstalled the OS from the thumb drive and everything worked.

Oh great! This didn’t work for me but removing the second internal (SATA) drive did. I’ll leave this second fix here in case somebody else has the same issue.

Set the correct booting priority order and reinstal Roon Rock.

1 Like