Failed to initialize audio device again

Roon Server Machine

Intel 8559U Nuc
M.2 SSD and external SSD’s
32GB Ram
Windows 10 latest updates

Networking Gear & Setup Details

Gigabit Fibre connect
Asus AX-GT11000 Router
NordVPN
iPad with Roon remote using 5ghz wifi

Connected Audio Devices

Topping D10s Optical Bridge
Chord MScaler
Chord Hugo TT2

Number of Tracks in Library

Lots, but small in comparison to many roon users.

Description of Issue

When using Qobuz and Roon, if I use wasapi mode at times I get the “failed to initialize the audio device” error, it only happens when using wasapi and when tracks change sample rates, possibly also bit depth too, but I have yet to confirm this. The funny thing is, when taking the Topping D10s out of the loop, the problem doesn’t happen when using Chord MScaler and the TT2 in both wasapi and asio modes, it also does not happen if I use the Topping D10s in Asio mode.

Basically, if I want to use my Topping D10s as an optical bridge, I can’t use it in wasapi mode as within a couple of songs it will stop when sample rates change, however asio works perfect.

I only use the D10s as an optical bridge as my nuc does not have an optical output port.

So does anyone have a fix for this as I see that this is a common problem.

Cheers in advance for any input by others.

Edit

I have tried disabling exclusive mode, but then playback is not bit perfect so says the green ball. Also the only way to get it working in wasapi mode once it errors out is to unplug the usb cable and plug it in again, that kinda resets the connection and gets it back working until it decides to error out again, also it’s random, at times I will get an hour or so without any problems, then all of a sudden it happens when changing to the second track with a different sample rate.

Hi @Amberlamps,

Wasapi is Microsoft’s in-house native sound driver for porous access to the Windows system mixer. The driver’s intended use case is to allow application audio to blend seamlessly with system notifications. To that end, it downsamples and transcodes everything into the selected audio format of the system mixer unless you have toggled on Exclusive Mode.

Thus, if you are changing the source content in a playlist or Roon Radio, you’re downsampling before routing everything through the system mixer, and then through the Topping DAC.

ASIO is a third-party driver for professional audio use cases that grants an application exclusive control, regardless of source content, of a single endpoint. It bypasses the system mixer on Windows entirely. It’s no surprise you don’t experience these issues in ASIO mode on the Topping DAC.

Topping also offers their own audio drivers for Windows as an alternative to both Wasapi and ASIO. You might investigate those and try out their performance for your desired audio chain. There was a driver released in October that might help:
https://www.tpdz.net/newsinfo/874980.html

Hi Connor.

I see, so it’s better to use ASIO than wasapi mode, I was told numerous times that wasapi was the better choice, combined with exclusive mode, which is always enabled on my end.

It is the topping drivers that I’m using, version 5.62 if I recall correctly and I think those drivers only support asio, so maybe thats where the problem is ? To be honest I only bought the topping dac / optical bridge so I could basically have a more or less pure optical signal going from the topping and in to my mscaler, and from there in to my Hugo TT 2. Just to see if it made any difference, which it has, I think it sounds better with the topping than without it, I only bought it as my nuc doesn’t have an optical out.

Thanks for your help and I will just use asio from now on.

emphasized text

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.