Failed to load media + Too many failures. Stopping playback [Resolved]

I am running Roon from Sonictransporter and everything worked great until I changed my wi-fi router last night.

Now when I try to play something in Roon, I get:

Transport: Failed to load media
Transport: Too many failures. Stopping playback

Details of my system/setup:

  • Roon Server v1.4 (build 294) stable
  • Sonictransporter runs Linux
  • Music is stored on an HD attached to Sonictransporter via USB
  • I’m controlling Roon via an iPad
  • The collection size is about 18k - 19k tracks

My Sonictransporter is hardwired to the router and I can reach it from the network, but when I play Roon, I get the errors.

I run HQPlayer on a headless Mac Mini that runs Windows 10 that’s connected to a Sonore UltraRendu. The Mac Mini machine is on the network and gets internet access as well, so the local network seems to be correctly connected and working.

Here’s what I’ve done so far to troubleshoot:

• Powering down Sonictransporter and rebooting from SonicOrbiter
• From within Roon -> Settings -> Storage, I Force Rescanned the music folder

None of these things worked.

I copied the Roon Server Diagnostics and have those available in a TXT file if you need those to review.

Any recommendations/advice/suggestions? @Eric? @andybob?

Hi @Gary_Gil ----- Thank you for the report and sharing your feedback with us. The insight is appreciated.

Moving forward, to help aide in our evaluation of this behavior you are experiencing during playback may I very kindly ask you to please provide the following:

  • While some of this may sound elementary, during your troubleshooting have you…

    • Confirmed that the HD attached to the ST (via USB) is fully connected to the unit?
    • Rebooting the any networking hardware currently in play (i.e the new router, switches, etc)?
  • Please verify the make and model of the new Wifi router that you have integrated into your setup. Furthermore, besides the mentioned router are there any other networking devices currently in the chain of communication?

    • Additionally, what was the original router that was in place?
  • Please verify the make and model of the device the UltraRendu is currently feeding.

  • When you receive the mentioned error messages…

    • It is when you are playing to the mentioned audio zone (i.e HQPlayer on a headless Mac Mini that runs Windows 10 that’s connected to a Sonore UltraRendu.), correct?

    • While it is a touch unclear if you are making use of other endpoints (please verify), my assumption is that you are experiencing this issue when streaming to all of your audio zones, yes?

    • Do you notice any patterns in this behavior? For example, does it occur with all sample rates/file types?

  • I will be contacting you via PM momentarily to collect logs from the ST.


Hi @Eric

I confirmed that the HD was attached and I rebooted all networking hardware.

The make/model of the new wi-fi router is a Netgear Orbi AC3000.

The UltraRendu is the Sonore UltraRendu v2.5.

I receive the error message when I am playing the audio zone: HQPlayer on a headless Mac Mini that runs Windows 10 that’s connected to a Sonore UltraRendu.

I do not see any patterns of behavior. It behaves this way on any track I play.


You might try eliminating HQPlayer from the audio chain and play Roon straight to the end point and see if you have the same issues.

Good point @Rugby!

I’ll try that this evening.

@Rugby I tried going straight to Roon and it displays the same exact errors.

@Eric one more data point. I just discovered that Tidal works fine!

Hi @Gary_Gil ----- Thank you for the follow up and your patience. My apologies for the slow response as I have been out of the office for few days.

Moving forward, I can confirm that the logs have been received and are now with our tech team for evaluation. Once my report has been updated I will be sure to share the team’s thoughts/findings with you ASAP.

Lastly, I wanted to ask about these recent observations you have made over the last few days. You mentioned that when you bypassed HQPlayer you still ran into the same errors. Can you provide some insight into the test conditions you made this observation with (i.e was this still while streaming to the MacMini Win10 endpoint? Was this directly out of the ST?).

Additionally, were you able to give the following a shot yet? See below.

  • Rebooting the audio zone having the issue as well as any relevant networking hardware.

    • From your first post:

    “Powering down Sonictransporter and rebooting from SonicOrbiter”

    • From my follow up:

    “Have you tried …Rebooting the any networking hardware currently in play (i.e the new router, switches, etc)?”


Hi @Eric thanks for getting back to me.

Yes I was still streaming to the MacMini Win10 endpoint. I’ve never streamed directly from ST, in fact i wouldn’t know how to do it. :slight_smile:

Yes the only zone I was using was the HQPlayer running from the Mac Mini with the UltraRendu endpoint in NAA mode.

I then bypassed HQPlayer and went directly to UltraRendu in Roon mode (changed in SonicOrbiter).

Yes I rebooted all of my network hardware in play and the problem persists.


  • Gary
1 Like

Hi @Eric,

I am wondering if perhaps there is a permissions issue with my music library connected to SonicTransporter. Previously I was able to access SonicTransporter and the attached USB storage from my Mac and drag files freely to my Mac, but it’s now giving me the following permissions error.

46 AM

@agillis do you have any input on this?

  • Gary

Yes that does sounds like corruption on the drive. Attach it to your computer and repair it. Also if you have not already done this reformat the drive to exFAT. We find this format gets corrupted less.

1 Like

Ok will do. Thanks @agillis!

@Eric @agillis Well I purchased a new HDD for my media drive, and formatted it as exFAT, then moved my old library of music to the new HDD and plugged it into sonicTransporter and low and behold… I still get the same error messages:

Transport: Failed To Load Media
Transport: Too many failures. Stopping playback.

Very frustrating!!!

Any ideas?

@Eric @agillis good news… I finally got it working with no errors.

Initially with the new drive, Roon recognized it and I could see it was reindexing the library, but it still wouldn’t play tracks without generating the errors.

Today I tried again and tried rebooting sonicTransporter and then it did not recognize the attached music drive, so I had to make a few adjustments within sonicorbiter and I got it working.



Good to hear you have it working.