Failure of Tidal to perform within Roon, while it performs well outside Roon

Core Machine (Operating system/System info/Roon build number)

Operating System

Version 1.0 (build 186) Stable

Server Software
Version 1.7 (build 555) stable

Roon Labs Software

Version 1.0 (build 12) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Draytek Vigor2860 router
Netgear GS110TP 8-port POE switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Meridian Audio – MS200 (x12)

Meridian Audio – MS600

13 devices in total

Description Of Issue

Tidal has been erratic for a while for me IN ROON.

I thought it might have been my internet, but am now convinced it isn’t.


There are some albums that I play where I get a horrid screeching sound as Roon first shows the moving bars suggesting playing of a track, and then hops onto track2, and frequently skips to track 3 before coming to a stop.

NOTE 1: if I then move to my computer and play the same music direct from Tidal: no problem.

NOTE 2: this seems random. Some albums work, some fail.

Last night I was served Thievery Corporation - “Symphonik” as a recommendation. I tried to play it. Didn’t work. So switched to my PC.

Any ideas?

Thank you

Hi @Robert_Markwick,

Does the same behavior occur if you play to System Output of a remote?

Does local content work okay?

Local content is fine.
I am unclear what it means to play to ‘system output of a remote’ - sorry.

Hi @Robert_Markwick,

You can play to System Output of a remote by going to Settings > Audio and choosing System Output. This will test playing TIDAL to a different endpoint which will help us determine if this is device specific. Thanks!

I remain confused.
On My iMac I have tried TWO system outputs. In Roon/Settings/Audio, the top offering is “This Mac” and there are two options to enable. One box says “Audio will play out of the core device”, the other says “Core Audio”. Are there any further setting required? I have tried both optimism. Neither yield sound, although ion both cases, my Tidal choice seems to be playing (according to the graphics).
I tried to play a Tidal Album (a new release) though Roon through my normal our put options, and got the screeching sound again. I tried you suggestions. Did not work.
The only thing that does work is playing the new album through the Tidal App on my Mac. Am keen to resolve!
Thank you

…adding…sometimes it helps to logout of Tidal (in Roon) and then to login again., Note, I have a family subscription, and Roon is the ONLY user of one subscription. So, no conflict with other users. I have TWO Roon Subscrioptions (one for UK and one for France), and I have Family subscription on Tidal with separate dedicated subscriptions for each location. The problem seems only to occur in ONE location.

Thanks for the details, @Robert_Markwick.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs as well as the track that fails to play? Then respond here with that time and track, and I’ll make sure we review the diagnostics related to that timestamp.

I am away from the property until the 20th. I will revert, when the problem reoccurs. thank you


I have previously written about a problem where I would get a horrid screeching sound as Roon failed to deliver on play requests sourced from my Tidal Account.
I have 2 Lifetime Roon licences for 2 separate locations.
I have a Tidal Family account (I think it’s called), which allows for 5 logins. I have 3 so far. 1 for each Roon, and one for my mobile phone.
I have just switched login for my Roon(2) account, using my phone login. Eureka. It works.
So…it seems that the third Tidal account, for whatever reason, caused a problem with Roon.
Most bizarre. I will delete the tidal account. Create an alternative and see if that works.
Anyone else has problems sourcing Tidal through Roon for one account, but not another?

Annoyingly - problem has reverted, despite using a new login for Tidal. V frustrating!

Sorry for the troubles, @Robert_Markwick!

Can you confirm that your setup is the same as listed above:

Do you experience this with all endpoints?

Have you noticed any patterns? Is it certain content that seems to trigger this?

  1. I am just an ordinary dope at home, who knows very little about all the stuff above. I sent the list to my installer, and he say that all is as you say.

  2. It would be way better to include my “installer”, who has installed TWO very similar systems in two different locations, both using ROON (lifetime sub), but I can’t do that as we are not using email to solve this. a bit frustrating!

  3. Please note: one location is Central London, and one is in France. Internet in the former is superior, BUT, I don’t have Internet issues with any other services that we use in France (Zoom calls, Netflix, Apple stuff, other Video Streaming services etc).

  4. As I have previously noted, streaming music DIRECT to phone and PC (from Tidal, not through Roon) presents NO PROBLEMS in France.

  5. I have recently, in a last ditch effort, taken out a Qobuz subscription. It’s not perfect, but it’s a lot better. Roon “processes” Qobuz better than Tidal here in the Alps.

  6. When Tidal wouldn’t work, I would frequently get a nasty screeching sound as it ‘gave up’. Giving up would frequently result in skipping tracks, before finally stopping.

  7. Qobuz works most of the time. There are times when it can’t “process” a track (at the start of a request, eg a new album), and then skips and stops on the next. I then revert to the original (first) track, and it begins to get get going. Hurrah!

If we are going to progress this (and I so wish we could), then I believe it may need to be through a three-way conversation between me (Alps), Roddy the installer (London), and Roon.

My Qobuz streaming quality is Hi-Res 24-bit / Up to 192 kHz

(With Tidal is tried all levels of quality (to the lowest))

I have managed to resolve this.
I have taken up a Satellite Broadand subscription, where speeds are now much higher.
Roon is clearly v data hungry, and puts demands in Broadband Sevices which are way above those of streaming (music OR video) services.

SEPARATELY I have written abiyt recent, pretty frustrating Meridian issues (having to REBOOT my speakers all the time). A work-around by inserting Sonos in between has helped. I am hoping that the New Roon (apparently there is a Beta) will solve this, and low again for direct Roon<>Meridian.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.