Failure to add to library from TIDAL

I’ve come across a couple of classical albums on TIDAL that have both failed to add to my library.

If you try to add from the main album screen by clicking on [+ Add to Library] then the blue [NEW] ribbon appears, but moments later the screen is white with a pop-up saying “This album has been deleted” along with a [Browse Albums] button. If you try to add by right clicking on the album list then nothing happens.

The albums I happened to have noticed this with are

Vivaldi Cello Sonatos - Marco Ceccato
Mozart: Divertimenti - Scottish Chamber Orchestra Wind Soloists

Trying the second of these again the symptom on the main album screen is now that a downloading icon appears briefly in the top right but nothing further happens.

Any ideas?

(It’s outstanding what you’ve done with the classical music interface by the way!)

The second of those has now added, but the first still has the problem. Both can stream fine from TIDAL.

Hi, I tried adding the first to my library. I was successful. This is Vivaldi Cello Sonatos - Marco Ceccato.

I am playing it back now.

Strange. I can play it too, and I can add other albums, but adding this one always results in this error:

Maybe related, maybe not: I have found several albums in Tidal that do not work, either for streaming or offline. In Roon and some other systems it just fails. On one platform (I forget which) I get a more explicit message that “the publisher does not allow streaming for this album”. You might want to try this album to see if you get that message. Unfortunately I don’t remember if it was Windows or iOS, and if it was the app or the browser.

Another question is why Tidal would list albums that they refuse to play…

Still having this problem @londoner? I just tried and like @bplexico, I’m able to add the album to my collection.

Let me know if you’re still having this issue, and we’ll take a look. And sorry for the slow response here!

Hi Mike,

Thanks for getting back to me.

I can still consistently reproduce the problem so it must be something wrong with my local database.

If it helps in diagnosing it I discovered that I can add the album by selecting it as a favourite on Tidal. The album then appears as the first in my list of “Recently Added” but without a “NEW” blue ribbon on it. If I then remove it and attempt to re-add it from within Roon then I get the original “This album has been deleted” behaviour.

The album streams fine from TIDAL. It also plays fine if I’ve added it using the workaround method by selecting as a favourite in TIDAL.

Let me know if you need any more information.


Thanks Nigel – I’m going to follow up via PM and we’ll get some more info about this issue.

A post was merged into an existing topic: Build 99 64 bit add to library still not working most of the time