FAN running constantly on new NUC8i7BEH

Hello all.

I have a new (4 weeks old) NUC8i7BEH, with 16GB Ram, 250GB M2 HDD, in the start I used my NAS for music files, around a week ago I installed a SDD (Samsung MZ-76E1T0B/EU Internal SATA SSD 860 EVO 1 TB) for music files, since then the fan have been running all the time, it didn’t before.

Is there anyone that have a good idea why, I can´t believe that it is because of the power need for the SSD?

BR Morten

Is it stuck importing? Do you have the spinning thingy top right in the menu bar? Have you rebooted?

No spinning icons, and I have rebooted more than one time… My library is not that big, only 1700 albums.

Can I somehow start from scratch, I mean clear the data base and have re-scan the HDD?

Br Morten

What operating system are you running on your NUC8i7BEH? Is this Roon OS (ROCK), Windows 10, or one of the popular Linux distros (Arch, Fedora, Ubuntu)?

It is ROON OS (ROCK) in latest version

1 Like

Is you library still being analysed? You can check under Settings Library

Does it feel warm or is the air coming out warm…this would indicate some CPU utilization - or maybe the SSD is heating the case and the fan is cooling it.

in the BIOS you should be able to see the fan settings and speed if running

1 Like

No, all is imported, and analysed, it did in real time as I copied from the NAS to the internal HDD.

There is no warm air coming out, therefore I am puzzled…

Did you modify any BIOS settings when you added the new SSD? Just wondering if the fan control setting has changed at all.

Yes, the boot order, M2 first and then the new ssd

1 Like

Hi Morten, I think they have been asking if you verified the fan settings in the BIOS.

Try to update BIOS to version 0085.
BIOS release notes:
“Fixed issue that made system fans spin over 3000 RPM regardless of workload”


Ahh ok, no I didn’t

Cool, I will give it a go.

Well I tried updating the BIOS, the Fan is still running, it is slow, but it is running.

I have attached a photo from the setup screen, is there any recommendations I could try?

BR Morten

You have fan off selected and fan should be off when temperature go under 40. Problem is that temperature is basically never that low. In normal settings (no fan off used) fan runs all the time.

I also had same issues (nuc8i3) and did not want fan to keep spinning all the time. I tried raising fan off temperature but result was that fan stopped for minute or two and started again. If you try it do not raise it too high!

Even if fan is nearly silent I did not want it to spin all the time and got Akasa fanless case…

Intel forums also have information about fan settings:(more can be found with search)

If you care about fan noise, you should get a fanless chassis.

Fan Control Mode -> “Quiet” or “Fanless”.
But “Fanless” is not really fanless ))
I use “Quiet” for ROCK.
Also for ROCK I disabled some unused built-in devices, such as Bluetooth, Wi-Fi, audio, etc.
When NUC is not busy playing music, it is totally silent, but during playback and Roon library update I hear fan is running anyway.

…or if you do not like fan spinning 24/7 even if it is almost silent. I just could not leave that running all the time :grinning:

Thanks, you are a champ, it solved it…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.