Fatal error message preventing Roon from operating and operating self-powered speakers

Core Machine (Operating system/System info/Roon build number)
Core: Roon Nucleus 1.7, build 505
Laptop for Remote: Lenovo Ideapad 320-15ABX using windows 10

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Spectrum High Speed internet, Arris TM822 modem to ASUS RT-AC1750 802.11 AC Dual Band Router. Roon connected directly to ASUS router via cat 6 ethernet cable. Laptop via wifi downstairs.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Upstairs system has USB cable from Roon Nucleus to McIntosh MA5300 integrated amp with built in D/A converter. Downstairs laptop is connected via USB cable to Vanatoo T0 self-powered speakers.

Description Of Issue
The problem I am having is the Roon remote software stopped working on the Lenovo Laptop with the fatal error: “Object reference not set to an instance of an object”.

What does this mean?

I have updated drivers, scanned for malware, scanned files, etc. I have uninstalled and reinstalled the Roon software. It worked fine after first installing Nucleus a few weeks ago. I first started having problems and had temporary success with updating drivers, but was only a temporary fix. Failed the next day on reboot.

The audio output to the Vanatoo T0 speakers works fine streaming a radio station over the computer.

I suspect there is a setting issue (maybe video?) or Windows corruption preventing the problem from running.

I may just get a Roon compatable streamer from BluSound and just get the whole system off computers!

Roon Nucleus works better than Roon Core on Windows computers. If a fix is easy, I’ll try them. Maybe I should try to see if Roon will operate with the Vanatoo disabled?

I would at least like the Roon operating display on the laptop even if I use another device to stream and control the Vanatoo active speakers.


Looks like a OOP coding problem, IMHO.

The message is saying that the referenced object has been defined, but not instantiated.

A compiler should catch this, so it seems that it might be occurring in code interpreted at run time.

Just my 2 cents from looking at the outside of the black box.

Yeah, I know. You asked what time it was and I told you the parts in a clock. :smirk:

Tagging @support for you.

So what does this mean for someone who is not a computer tech person? Is windows corrupted (happened on my desktop)? Do I need to reinstall windows?? I ran all kinds of computer optomization software, but did not fix this problem. Just hate Windows 10!

That’s a question for Roon support. I’m thinking it isn’t a WIN10 problem, but who knows.

Perhaps your device doesn’t support the now higher feature use of Open GL3.0

This is not normally an OS issue but can also be because your hardware is not able support the Open G3.0 needs too. I would read the other references in search on this community for “Object reference not set to an instance of an object”

Someone from support should be along to assist in due corse too.

Hi @Michael_Gormley,

When did this issue start occurring? After the 1.7 update? After a Windows update?

Starting out, let’s try the following:

  • Download the latest graphics drivers for your device
  • Download the latest .NET framework
  • Reboot your Core
  • Try starting up Roon

Let us know how it goes after doing the above.


I did update all drivers about a week ago and Roon worked on the laptop for a day or two before going back to the error message. I suspect windows reverted back even though the driver updater program says all drivers are up to date. Will isolate the video graphics and .NET framework. Roon Nucleus has been turned on and off recently. That part of the system works well. I think the problem started around the Roon update of 1.7 to the laptop. Life would be a whole lot easier if all systems were Linux based instead of Windows!

1 Like

I went through all the indidual device settings, but windows claimed they are the latest versions. I had to reboot nucleus and the synology drive for another issue. Now for some reason, Roon now runs on the laptop! Can’t get the Vanatoo powered speakers to work off the USB yet (rapidly skips), but this must be some kind of device setting. I know I’ve seen it before, just have to find the right setting. I will get this laptop off the Vanatoo speakers soon.

Hi @Michael_Gormley,

I’m glad to hear that the laptop is working now! If you experience this issue again , please let us know!

Generally, it’s best to install the latest drivers directly from the manufacturer’s site — The Windows driver updates aren’t always the most reliable.

It sounds like you’re familiar with the speaker issue you mentioned, but if you continue to have issues please feel free to open a new support thread about this and we can take a look.


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.