Ffmpeg issue [Windows N]

I have tried everything for two ours to install the FFmpeg plugins. No success. Roon is not even starting. I don’t want to setup Roon Rock. Just Roon on my Main PC. Why is this so hard. My system cannot find any directory called \ROCK\ or anything like it. It’s just ridiculous to pay so much for software and then the installer doesn’t even include all that’s needed. Absolutely embarassing and a big fail and thimbs down for the Roon developers!

Hi Daniel,

Fellow user here. I am not sure what you are trying to do. Roon ROCK is an OS install that turns an appropriate Intel NUC, into a server running RoonServer, and nothing else. In an install of ROCK, you need to add ffmpeg.

If you are not installing ROCK, but, are installing on Windows or MAC, then the mp3 decoder will already be part of the system and no ffmpeg installation needs to happen.

What OS are you installing RoonServer on?


I’m installing on Windows 10. When I open Roon (I installed the full package), I get the error message that Codecs are missing. I already installed FFMPEG to no avail…

This is not a Roon issue. Something is badly messed up with your Windows 10 installation. You need to find a way to repair that first.

What version of Windows are you using ?

Windows N, for example, requires additional files to be installed to support media playback.

1 Like

I have completely reinstalled Windows now and the problem remains.

Thank Andy. This did the trick! Reinstalling Windows wasn’t even necessary.

1 Like

Glad to hear that you got it working. I’d never heard of Windows N. Did not know it was a thing. I’m still not sure what it’s for, but I imagine there are lots of things that don’t work with it without extra work.

It was one of these consumer choice rulings where the media bundles were stifling choice…

1 Like