"FILE LOADING SLOWLY" message constantly

I have this problem too with an iPad Pro as an endpoint.

The bedroom, late at night, is the only time that I use the iPad as an endpoint and I get constant ‘an audio file is loading slowly’ messages. But I’ve noticed that it’s a lot better after 1230 when, presumably, other people in the block have gone to bed and the bandwidth is freed up. Not completely better but much better.

It’s also better (but not perfect) closer to the router but it’s not needed then.

Roonserver and router is in the lounge of an apartment.

Hi @Graeme_Allan ---- Based on your description/observations that does sound like a networking/bandwith issue to me.

What type of router are you using and are there ANY other networking devices involved with your topology? If you have the ability to do so, is there a device that can act as a Roon remote that you can test a hardwired connection with to see what the experience is like?


I had a whole evening the other night with no issues and thought that the latest software release had sorted it but the frustrating problems returned yesterday.

My equipment:
Apple MacBook Pro running RoonServer - 2.66/8gb RAM/2 core duo
Seagate External hard drive
All music is RedBook
Macbook is connected via ethernet to TPLink switch
TPLink switch is connected to NOW TV router
Ipad Pro endpoint

At its worst I get the FILE LOADING SLOWLY message constantly, not allowing a single track to play. Sometimes a track plays almost to the end before stopping. Roon crashes completely sometimes too on the iPad as it did last night.

Is all the content local or some from Tidal?

All local. I have no problems with my MS600 as a hardwired endpoint.

Hi @Graeme_Allan ----- Thank you for the continue feedback! I have split your posts out to their own thread so we can address this behavior with you directly.

Continuing forward, may I very kindly ask you to please provide the following feedback:

  • Just to make sure I have this correct, all of your endpoints are functioning as expected but the iPad Pro is the only device currently exhibiting this behavior, yes? Is the iPad Pro the only WiFi based endpoint in your setup?

  • Can you provide me with the specs of the “NOW TV router” router you mentioned in your post?

  • Please verify the model of the TPLink switch you are currently implementing.

  • What is the experience like if you use Wifi (temporarily) MBP hosting RoonServer instead of the hardwired cinnection and play directly out of the internal speakers on that device? Do you run into the same issue as the iPad pro?


Hi Eric,

My other endpoint - hardwired MS600 - works great, no problems. I don’t use my iPhone as an endpoint but after testing it also suffers from FILE LOADING SLOWLY.

Specs of my router … made by Sky CP ltd. Model number NR701
TP Link switch Model no. - TL-SF10050. 5 post 10/100 Mbps Desktop Switch

I’m not sure how I do the final thing you ask. If the MBPro is running Roonserver I don’t know how I get Roon to play out of the internal speakers.
I have, though, enabled the MBPro wifi and am now playing Roon through the iPad Pro to see if there’s any difference. No outages/crashes yet but early days.

Thank you for touching base with me @Graeme_Allan and taking the time to provide the requested feedback. Both are very appreciated!

In regard to the proposed tests:

" What is the experience like if you use Wifi (temporarily) MBP hosting RoonServer instead of the hardwired connection and play directly out of the internal speakers on that device? Do you run into the same issue as the iPad pro?"

  • If you look on your remote device you should see the following option: “Connected to core”

  • I would use the “built-in Output” zone with “exclusive mode” enabled in the “device setup” window.

  • Once the zone is active I would confirm how playback performs with both a hardwired connection and with Wifi.


I had this problem a couple days ago and it’s kind of odd what the source was: the endpoint was having some issue and in need of a restart. I had never had issues with my network being slow before, though it sometimes would take time for a track to start playing while the NAS is spinning up. Room was patiently waiting for that without giving me this message.

After restarting literally everything involved on the source side (NUC, NAS, access point), I still got this message. So I restarted the last thing that I could, which was the end point (a Pi running DietPi), and voila, everything worked great again!

It’s weird that Room complains about the file loading slowly when it should know that the end point is pushing back and slowing things down/not able to deal with the data. It would make diagnosing and fixing the problem much easier if the message reflected what was going on. I even wonder if some of the issues people are having with TIDAL are caused by the end points, but the message is misleading there as well.

Doh! I should have known that. Thanks, Eric.

So, last nights testing was 100% problem free using the Built In Output over wi-fi. I’ve also had no issue using the iPad Pro as endpoint over wi-fi.

Currently testing the Built In Output hardwired but that seems fine also.

Does this point to the ethernet switch as the problem? Do I need an upgrade there? Any recommendations for a small ethernet switch?

Hi @Graeme_Allan ----- Thank you for the follow up and sharing the results of the proposed test. Very pleased to hear of the positive outcome!

Before we discuss replacing the mentioned switch I would like to see what results we get when the switch is temporarily bypassed. Can you please verify for me what the experience is like if you connect the MacBook directly to your router?


Hi Eric - I was one step ahead of you! I did that and it had no effect. I was getting as much file skipping as normal.

I also went and upgraded the switch, thought it could do no harm. I’ve now got the TP Link TL-SG105E. Sadly, I still get the same problems. May be better but its hard to know as it was always different - some days/evening better than others.

Graeme, I can’t help noticing that the switch you have is a managed switch. I had nothing but trouble when I had a managed switch in the network. I replaced it with a simple unmanaged switch, and all the problems instantly went away…

1 Like

Hi @Graeme_Allan ---- Thank you for the update and being proactive in your troubleshooting.

As Geoff points out in his post/provide link, we have indeed seen some issues pop up in the past (Example: #1, #2, #3) when managed switches are being implemented. I would recommend enabling flow control on the switch, as we have seen it help others