File or Qobuz loading slowly ONLY ON ANDROID DEVICES

Roon Core Machine

Innuos Zen Mini MkII

Networking Gear & Setup Details

Roon Core wired ethernet
Android devices over WiFi

Connected Audio Devices

Samsung Android Tablet and Motorola Android Phone

Number of Tracks in Library

Description of Issue

Tracks stop playing after about 5 secs with message about loading slowly then skips to next track and same happens.

This ONLY happens when streaming to the local Android device - ie using the phone both as Roon Remote and the endpoint. No problem streaming to my Windows Laptop over WiFi and no problem when using Roon Remote app on phone or tablet but streaming to a wired ethernet endpoint.

Have updated Core to latest version and tried reinstalling Roon Remote app but still have this problem. Also rebooted server and WiFi router.

Has been working fine up until now, not made any system changes anywhere. Points to problem with Roon Remote app.

Points to a problem with your WiFi.

Don’t think so 'cos I can stream over WiFi to my laptop using Roon no problem

And I can also stream from Qobuz to my phone or tablet when using the Qobuz app with no problem.

Problem still occurring. Any help from Roon here??

I’m not Roon, but interested in knowing about Android and core’s versions in use…

Hi there. Thanks for asking. I’m running Android 11 on a Samsung tablet. Roon Core and Remote are both ver 1.8 build 970. All software is up-to-date inc tablet and Innuos server.

Thanks, but I’m missing your phone’s OS info, because you made it an explicit point, that it …

Are you using any DSP? When your playing to the phone, check the Roon signal.path to check what the Processing speed is and and processing during playback. With Andorid Roon will be resampling to rate the device reports to it, in most cases its 48/24 but in some cases it can be higher. This maybe either tipping the balance of your WiFi as Roon sends uncompressed data to your device, native apps send flac which is lossless but compressed so has a smaller data footprint. So if they are using 2.4ghz WiFi it can max it out easily as it’s not so robust if many other devices also using the 2.4ghz band. I am having no issues streaming to my Android DAP on the latest version as a data point.

The problem occurs exactly the same on both phone and tablet,

Not using DSP, Roon appears to be sending data at 48/24 so that shouldn’t be problem as WiFi speed is 65Mbps according to my tablet. I have very few WiFi devices so I don’t think it’s a WiFi capacity problem. If it were then I would expect it to be more intermittent but it happens the same way every time, every track, playback stops after just a few seconds. So it looks more like a data handling / buffering error in Roon somewhere (no problem at all playing exactly the same tracks using the Qobuz app). Roon has been working absolutely fine for months, the problem just suddenly started two days ago.

If you have not yet, try restarting all your network gear just to see if it helps. 65mbs indicates 2.4ghz which can get oversaturated by other houses WiFi. It might have more cross channel interference from a neighbouring system. The rate it says is rarely what it is either that’s a max transmission rate not actual. WiFi is up and down all the time and Roon as I said is uncompressed and can just tip it over if this already borderline as pcm is much larger than flac. Given it was fine a few days ago and your other systems are ok it can often point to WiFi interference. WiFi isn’t the same minute to minute let alone day or day and now a neighbouring WiF system might have changed to be on the same yours.

I think I have identified the problem but not sure how to fix it. I’m attaching two screenshots showing the datastream from Roon when streaming a local FLAC file on my Roon Core server. One is to my laptop over WiFi which plays absolutely fine, the other is exactly the same file streamed to my Android tablet ovef WiFi, which stops after a few seconds. This one shows a whole load of rate conversion and upsampling, even though all the DSP is turned off in Roon. So any ideas why?

In device setup for your phone in Roon settings:audio you could try setting a max sample rate of 16/44 and see if that helps?

Not just an idea, actually.
It’s a well documented quirk that Android resamples all audio to 48kHz/24bit.

Some Android audio apps circumvent that limitation, but Roon is not one of them, unfortunately.
There are even several feature request threads regarding this limitation.

Anyhow, that doesn’t really seem to be your culprit, since processing speed indicates being capable of 33.1 times the current need.

Thanks for all comments and suggestions. Just tried setting max sample rate to 16/44 but made no difference.

I agree that it seems that the rate conversions are not causing the problem and it’s definitely not WiFi capacity, so I’m out of ideas.

The strange thing is that all was working fine until a few days ago when both Android devices suddenly started having exactly the same problem, but streaming to my Windows laptop is unaffected.

So how do I get some actual response from Roon support on this? (As I do actually pay for this service! )

As soon as your request comes up in their crowded queue, and tomorrow’s 4th of July…

Hey @Ian_Pickering,

Thank you for reaching out to us with your question. My apologies for the delayed response and for your wait.

I’m sorry to hear that you were having issues with your Android remotes. Since some time has passed I wanted to touch base to get your current status. If you’re still experiencing this problem and need assistance please let us know.

We’ll be watching for your reply and get back in touch as quickly as we can. Thanks!

Thanks for responding. Yes, the problem persists. I have updated both android tablet and core to latest Roon 1.8 build 988 and still have exactly the same issue.

@jamie , no respose for a week. Can you please assist with this problem, first reported 24 days ago.