Files Not Showing Up

Core Machine (Operating system/System info/Roon build number)

AMD Ryzen 3 2200G, 8G RAM, Win 10, Roon 1.7 build 511

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Google Mesh routers - Roon core device hardwired by ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Cambridge Audio CXN vers 1

Description Of Issue

Crazy thing. Imported a compilation album with 16 tracks to my library using iTunes. Files are .mp3/192 ( yeah I know, but it is an old album). All 16 tracks show up in the iTunes library and in the correct album file folder.
Roon only shows 14 of the 16 files. All the other files are numbered and named correctly.
I checked the file names and they aren’t unusual by Roon terms. Checked the “Skipped Files” in Roon and they don’t show up there.
Now, here’s the strange part: I went to “Tracks” in Roon and searched for the missing files by name. Both of them show up and Roon shows them both with the correct file path, right there in the album folder with the other files.
How is it that Roon can “see” that the files are there using the Tracks search feature, but doesn’t show them in the file list with the album?
I have re-scanned the album using Album Editor, and they still don’t show up.
Any ideas?


Hi @robert_vanarsdall,

Roon might have placed these tracks in a separate album — Can you share a screenshot of what you’re seeing? When you click the album link for these tracks what do you see?

Dylan -

Here’s what shows up in Roon when I select the album:

When I used Roon’s “Identify Album” feature, Roon shows the right album, but note that tracks 1 and 3 are missing:

Going straight to the core, the missing tracks are in the album folder where they should be:

And further perplexing, if I search for one of the missing tracks in Roon (Overview-> Tracks -> Search), Roon shows me the file in the album. If I then ask Roon to show me the file data, it shows me the file path and the file sitting where it should be in the album folder (that’s the overlay at the bottom):

I’ve uploaded the entire album to a shared folder for you to see whether there is anything wonky with files 1 and 3, but I couldn’t see anything. The files also don’t show up in Roon’s “skipped” folder. I have also tried deleting the album from the core, restarting the computer, and re-importing the album to the core with the same result. There’s something about files 1 and 3 Roon doesn’t like.

Album shared here:


Hi @robert_vanarsdall,

Can you confirm how you’re navigating to this album? You mentioned before that you can find the tracks from the Track Browser — If you go to the Tracks and click on the album link for that track what do you see?

Very interesting.

If I use Roon to search for one of the tracks, it shows up listed with the album as I previously showed.

If I search as you asked, using Tracks to search for the file and then clicking on “Album”, what shows up is this:

Roon shows the two missing tracks with the album cover but none of the other tracks on the album!

What’s going on here?

My guess is that somehow it was split into two albums, happens with messed up meta-data.

Try going to settings and setting Show Hidden to YES. If Roon suspects an album is a duplicate it will hide it by default. Then go back and see if you get 2 “Swamp Gold, Vol. 2” albums. If so, then select them both, hit the edit menu and choose merge albums.

Hi @robert_vanarsdall,

For some reason Roon placed tracks into their own album. The best option is to use the Merge Albums function to combine these albums. This should resolve the issue for you.


Couldn’t show both albums to merge until I used Focus. Went to Albums=>Focus=>Compilations. Then scrolled until I found the album listed twice, as you suggested. Right-clicked to select both albums, then clicked “Edit” in upper right corner. First choice is “Merge Albums”.

Bingo - All the tracks in one album where they should be.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.