Filtering for multichannel albums not finding non-primary versions

I have a couple of albums with 5.1 release added as an alternative release, but when I filter my collection by format -> 5.1 it only shows albums where 5.1 recording is set as primary. I’d expect it to show me a list of all albums, and when I click on them it should take me to the 5.1 recording I’ve chosen.

1 Like

Hi Chris,

There are a few options for you in this situation.

  1. In Settings > General > Show Hidden Albums set to Yes. However, this will be for all duplicates. ie. you may have high res and MP3 of an album and don’t really want to see the MP3.

  2. Focus on Format 5.1 and then also focus on Inspector > Hidden. However, this will only show your 5.1’s that are hidden and not the ones that aren’t hidden.

  3. Remove 5.1’s as Duplicates: Use #2 above and click on the album and then Other Versions button and then beside the 5.1 version, click the 3 dots icon and then Remove from Duplicates. So, the idea is to make sure your 5.1 albums are not duplicates.

Hope this helps.

Cheers, Greg

In my opinion, this is a BUG, and it’s not been solved after 3 years.
the main point in duplicates … is that you can select a primary version, the one you want to play. so, for example, in general i don’t want to play 5.1 tracks… as i have to use an alternative setup.
that’s why it makes sense to hide 5.1 albums.
but if i filter for 5.1 format, i expect them to be shown.

I’ve gone for the option of setting all my 5.1 albums (both local and streamed) as the primary version. That way they will show up in a simple Focus/Format 5.1 filter. I’m happy to leave it to Roon to do the mixdown to stereo when I play them on my primary HiFi setup.

If I wanted the stereo versions to be my primary versions, then I would have made a bookmark of Greg’s option 2 to filter on my 5.1 collection.

In my opinion, this isn’t a bug, but I can understand why some would not call it a feature… :slightly_smiling_face: