Finally got an RPi but No Sound

Ropieee flashed fine. I can see and configure it. Connected to my Emotiva pre-amp with built-in DAC via toslink but get no sound at all. Roon begins to show as if it will play then nothing. Also, not sure why volume shows fixed when I do not have fixed selected. If you need any more info let me know. Previous setup was with CCA via toslink and it was fine.

The Music looks like it wants to play and then nothing. the scrubber doesn’t move and then after a few seconds, Roon skips to attempt another song.

Volume control is fixed as the digi+ is a digital output. The ‘force volume’ setting in RoPieee only relates to USB (that’s the reason why the option is greyed out).

1 Like

OK but still have no output

no… that;s the weird part.

Can you send me feedback? You’ll find it on the advanced tab.
I can then have a look in the log files to see what’s going on.


Thank You

Hmmm… your hifiberry craps out when Roon sends data to it… :frowning:
Do you have (by any chance) another HAT lying around? Or the possibility to use USB?

No other HATS but might be able to use USB although not optimal since my pre-amp USB stage looks like it might just be a Bluetooth connection, not really sure. Need to see if I can find a cable. Damn it no USB-2-USB cables around. Guess I need to return the HAT for a replacement.

Thanks for your help

Ok, picked up a USB cable and everything works great (albeit, only at 96k) but the replacement HAT will be here later today (thank you overnight 1 day Amazon shipping).

Damn it. New HAT NO SOUND. SENT FEEDBACK. 244ab5e4e34a3382

@spockfish let me know what you see. Maybe it’s the Pi and not the HAT. Thoughts?

Yeah, same error being reported :frowning:
Could be the Pi… You’ve got one lying around to test with?

Hmmm… looking around I see that more people have reported this error with this specific HAT.
Could also be related to this specific HAT.


Crap. Any recommendations? Are there other HATS with Toslink?

Just tried coax and got a different reaction, no sound but at least the scrub bar was moving. Sent over move feedback. 7af30da7b23f73de

Thank you for your help

I myself got (amongst others) an Allo Digione using Coax.

1 Like

HiFiBerry Digi+ PRO… been around for ages, very well supported. Pretty rock solid.

Just concerned about anything HiFiBerry after 2 that don’t work.

No worries. I’ve had 5 and all have been rock solid.

A step above is the Pi2Design 502DAC. It has TOSlink, BNC and AES3 outputs. Really well designed.

And it uses the same HiFiBerry driver, which is supported nearly everywhere by now.

I wish I could buy that 502DAC fully assembled and tested. I’d just pay the extra to get a plug& play WORKING system.

Thanks but I don’t need all that, just need a working transport with Toslink or Coax to feed my DAC. ARE THERE ANY PREMADE out there?

No worries, I thought you were looking for a HAT for your Pi… but if you want a working transport that is Roon Ready, just get a Bluesound Node 2i and call it a day… a bit more expensive than the Pi solution of course…

The Allo DigiOne Player which Harry mentioned is great and comes fully assembled but you may still need to do SD card and ssh stuff… The Node 2i is much more plug 'n play in that regard.

Sorry, you are correct, I current do need a HAT but after 2 misfires I’m thinking of just returning everything and going with a preconfigured device. I see that Allo DigiOne is a preconfigured system. Might just go this route.

I need .11ac WiFi so the Node is out but I did look at that as well. My Emotiva pre-amp has a very nice 24/176 DAC so I really only need a transport.

I mentioned Node 2i (newer model)… .11ac is supported…


1 Like