Find my nas in Roon

Why it is so complicated to set my NAS on my roon core. My Nas is on, plug in the network and Roon don’t se it. Make it easy please. I enter the adresse like this //192.168.0…/music and nothing…my Asus laptop, my Ipad or my Android phone or Sonos see automaticly the network . We have just to click on the Nas et Bingo.
It’s very not simple with roon. Forget the path please. I try different solutions. I red the tutorial. It’s not clear and not just for me.

1 Like

A post was split to a new topic: How to connect Synology NAS to Roon

Why don’t you set up a network shared drive for the Roon core, such as say R:, then you can use that just like any other drive.

Hi @pierre_jubinville,

Thanks for the feedback here. At the present time, we only support manually adding network storage locations, but I can certainly take a look with you to resolve this issue.

Can you let me know - What kind of NAS are you trying to add to Roon? What is the model/manufacturer?

Just to clarify, you tried using the different notations from our Add Folders By Path guide?


  • If your Roon Core is running on Windows, the path to your networked folder might look like this:


  • If your Roon Core is running on Mac or Linux, the path to your networked folder might look like this:


  • After you’ve entered the network path in Roon, enter the credentials required to access your NAS. If a username, password, or workgroup isn’t required to access your NAS, just leave the relevant fields blank and click Add Folder

It looks like the notation you were using above is with a forward-slash, when you should be using smb: before the forward slash.

Can you please share a screenshot of the error message that appears in Roon when you try to add the share?


Hi Noris
I’nm sorry for the delay. I have a Synology DS218. I try to add folders by path but it does’t works. My core is a Nucleus. Question: were I can find to right adress or path. I really don’t understand what to do. I have a folder name Music in my Nas. the Nas software is install on my laptop Windows 10. But I really don’t know what to do.

OK I find my new path // . I can see my music on NAS but when I try to add directory I can’t import the entire catalogue but just one file by file. What can I do to star the global import?

Hi @pierre_jubinville,

Can you share a screenshot of what you’re seeing in Roon? You should be able to select the top-level music directory and press “Select This Folder” to import all tracks from the folder.

There should also be an “activity spinner” in the top right-hand corner letting you know the progress. Do you see this on your end as well?

Oh thank You Noris. It worked

1 Like

Happy to help @pierre_jubinville!

great community

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.