Finding iTunes library

Roon not accepting my path for tunes folder. I am a first time user and my setup is super standard. Running iTunes 12.2.2 and OS X Lion 10.7.5 I am trying to add a new watched folder and have entered my file path and checked the box for sharing the xml file. Still will not find it. I have checked the IP address and everything is on the same network.

Just cannot get Roon to accept the path. Any help would be great.

Roon has a minimum requirement of Mountain Lion (10.8) and that may be the issue here as there were some big changes between 10.7 and 10.8 in terms of storage access.

I’m honestly surprised that it installed as AFAIK it pops up an error if the OS rev is too low (at least it did on a 10.6.8 system).

I wondered about that. I think it’s time to retire the old bird. Will have to transfer my library to USB drive and mover over to my windows 7 PC. Thanks for the help.

OK. moved over to my Windows 7 pc and installed itunes. Put the path into Roon and it is now telling me that my key has expired. Any thoughts?

Unfortunately, no. If you can post a screenshot of the error that you’re seeing that would be helpful. In the mean time I’ll page @support.

1 Like

Here you go

Hi @V8M3 ----- Thank you for the report and my apologies for the troubles. I just want to make sure that I am conceptualizing the steps you’ve taken thus far, correctly.

  • You copied your library to an external USB drive and moved your Roon core from your MAC over to your Windows 7 PC.
  • You then launched Roon on the PC and tried to add your iTunes library in the storage tab.

Can you verify for me that you:

A) That your MAC is no longer being listed as a core and if it is still in use that you are running it as a remote or end point.

B) You removed this storage location (iTunes) from the previous core and then re-added to the new one after the migration.

Can you please provide the following information:

  1. The specs of the new core machine and your setup as seen here.

  2. Can you confirm where your itunes is being accessed from? Based on your screenshots this would appear to be some sort of network storage device. If that is indeed the case, having the make and model of the unit would be helpful as well.

Furthermore, I see you’re using the following path to access iTunes on the Windows machine:


Please be advised, as our knowledge base article states when accessing NAS storage on Windows:

“…If you’re having problems mounting your NAS on Windows, you can try using the NAS drive’s IP address like \\892.168.1.135\Music…”

Lastly, I think it is important to point out that we have seen some issues in the past with users having problems accessing iTunes via network storage. However, with 1.3 right around the corner this functionality should be improved upon.


Ok so I have successfully downloaded and set up Itunes on my Windows 7 PC. I have also removed the USB hard drive I had directly attached to the Discovery which was working. I have it attached to my PC with the new Itunes download. On my PC everything works. As far as software all I have is the app on my iPhone and then downloaded Roon Essentials on my PC.

No matter what path I enter, I either get invalid or key has expired. I have tried about every path so apparently I will need some very specific instructions. Right now my external hard drive is located at F:\Itunes\Itunes Media and I do have the box checked for Share Itunes Library XML with other applications. SO I have tried that path and also tried it with the IP address of my pc in front of it with no luck.

Wait, you’re running Roon Essentials? I didn’t even think that would work in this config! (Well, I guess it isn’t). Essentials is designed for specific 3rd party boxes like the Discovery. To run on your PC you’ll need to download and install the full version from

Uninstall Roon Essentials from the PC and install the full version then give it another try.

What a second here. It appears you’re own the Elac Discovery which comes with Roon Essentials.

So, you do want to use the Roon Essentials for Windows control app from the Elac website (which it looks like you’ve done).

So the question is, does Roon Essentials support iTunes synchronization and, if so, how do you set it up?

I think that’s a question for @support.

Cheers, Greg

OK so a couple of things. I do have the discovery and it is supposed to support itunes but all I am trying to do is get it to watch a folder which is my external hard drive. This is supposed to work because they have a menu for it same as Roon.

None the less I just downloaded the full version of Roon to check and it has located all my music and all is good on the PC. But apparently it will not work with the Elac Discovery. I get a warning message that says “We’ve detected Roon Essentials on your network. Roon Essentials and Roon and different applications. Please download Roon Essentials to proceed.”

So it appears that the only way I can get this thing to work is when I have a USB drive attached directly to the unit. Getting pretty close to throwing in the towel here.

I see that Chris is going to help you on the Elac forum. That’s probably better, since we aren’t generally familiar with the Roon Essentials and Elac hardware.

If you still have problems after Chris helps, be sure to come back here. We can get the Roon support guys to try and help.

Cheers, Greg

Hi V8M3,

Sorry for not getting back to you yesterday. I can walk you through sharing an external HDD connected to a Windows 7 PC with the Discovery. Windows 7 has a few odd requirements for doing this. I just finished installing a fresh install of Windows 7 and Roon Essentials and was able to share the folder successfully…

Just give me a call at the phone number provided in the private message I sent you and I can get you setup.


Chris Walker

@V8M3 ---- Dropping you a flag to make sure you don’t miss @Chris_Walker 's response.