Fire HD 10 hangs and quits Roon Remote when using TIDAL

Roon Core Machine = Intel NUC

Running Amazon Fire HD 10 as a remote. Haven’t used it over the summer as a remote. Now that the weather is changing I tried to use it and seems to work fine except when I go to Tidal. It opens the Tidal main page, but I am unable to click anything, not able to back out of the screen to the previous or home. App freezes and after about 30 seconds the it crashes and I have to restart Roon Remote. Tried removing and reinstalling. Was doing this before the 1.8 upgrade and still doing it after. Android phones and PC’s running remote are able to access Tidal.

Played with it some more and actually a little different than I initially described. I can scroll down look at new albums and scroll through them I can access my saved albums. However the app freezes when I hit the Explore tab.

Is it on the latest roon version?

Hi @Michael_Williams, can you confirm what version of Roon your Core and remote are running? The Amazon version of our latest update is still under review (though it should be available soon) and so a mismatch in versions could be causing some issues here. Keep an eye out for the update and let us know if there is any change after!

1 Like

Roon Optimized Core Kit Ver: 1.0 (build 227) Stable

Remote version is 1.8 (build 816) stable

I had this problem before the most recent update

Fire HD 10 updated Roon App automaticallly to build 831. Problem still exists. Canceled Tidal subscription and trying out Qubuz now. No problems encountered so far.

Hey @Michael_Williams,

It’s definitely been a while since your last post and we do appreciate the updates :pray: . I was wondering if there are any others you’d like to let us know of?

We’d love to help if there is anything we can do :nerd_face: