Fire HD10 remote losing connection

Picked up an Amazon Fire HD10 on Prime Day ($89!), installed Roon Remote (after installing Google Play Store). It’s working, but it loses connection to the Roon core every few minutes. It usually recovers after a few seconds, but it’s frustrating, especially if you’re forced to wait while it reconnects. My iPad running Roon Remote, in contrast, has no problem holding its connection to Roon core, for days on end.

Not sure this is a Roon problem, as there are several threads out there about flaky networking on the Fire HD tablets. Based on this thread, I have set the HD10 to hold a static IP address, but that didn’t fix it.

Anyone else seeing this? Ideas?


I may have this issue, but don’t use the tablet heavily enough to be sure. I generally start an album playing then switch the tablet off, so wouldn’t normally notice.
When it does lose connection it cannot reconnect and a reboot is the only fix. I did try to look for power saving settings (believing that this may be the issue) but couldn’t find them.

This sounds like the problem I was having with my iPhone. The solution was to change the band on my network that the device was on (from 2.4 ghz to 5 ghz). Maybe that works…

I tried that, forcing the HD10 onto the 5ghz band, and also on the 2.4ghz band. Still the lost connection problem.

I’m beginning to suspect this is a Roon problem after all, since I’ve had no trouble streaming audio to the HD10, both from Spotify and from websites through the Silk web browser that Amazon tablets ship with. Curiouser and curiouser.

Has anyone out there been using the HD10 without lost connections?

OK, I think I sorted it out. In the Settings of the Fire HD, there is “Power” category, and one of the items on that menu is “Automatic Smart Suspend (turn off wireless connectivity when you are not using your Fire”. That looks like the culprit. After disabling that “feature,” the Fire HD now has been running Roon Remote without dropping the connection for 6+ hours. So that looks like the fix that worked.

I’ve still got the static IP running on the 2.4ghz wifi band, but I suspect those were unnecessary (but I’m not going to mess with it now that it’s working!). I hope this proves helpful to other Roon users who need an inexpensive tablet remote.


Thanks for that. I have set mine the same and will report back.

Another report from the field - I tried setting a static IP and turning off the power saving feature. Regardless of whether I’m on 2.4 or 5 GHz, the Roon app will only stay connected for a minute or so before losing the connection and reconnecting. Other streaming apps play without a hiccup. I don’t doubt that the Fire HD10 has a poor antenna/WiFi implementation, but this still does seem like a Roon issue to some degree.

If anybody has any other tips/suggestions, I’m all ears.

I have no solution, but the same (though seems intermittent) problem with the Fire 10.

With continued use, I’m finding that the intermittent connection problem recurs if you go a while without rebooting the HD10. Once rebooted (with the other fixes mentioned above), the HD10 works solidly again as a Roon remote.

1 Like

I have a similar problem. When I startup Roon on my fire 10 I get a “waiting for remote core” message. The only way I can pass that message is to turn off “accept connections from remotes” in setup and then turn it back on. I am looking for an easier fix, if available.

1 Like

In the Settings of the Fire HD, there is “Power” category, and one of the items on that menu is “Automatic Smart Suspend (turn off wireless connectivity when you are not using your Fire”.
This has improved my connection with my Fire HD8. Thank you for figuring this out.

No changes to my network or devices, but I’m no longer having this issue with Roon 1.6 - music plays on the Fire HD10 without stuttering or losing connection.

That really works!

1 Like