First approximately 0.1 to 0.2 seconds of each track are chopped off

Core Machine (Operating system/System info/Roon build number)
MacMini (Late 2012) 2.5 GHz Dual-Core Intel Core i5, OSX 10.15.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
FiOS (Ziply) Gigabit & Wi-Fi using Airport Extreme/Time Capsule (v. 7.9.1)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Roon Bridge: MacMini (2018) 3 GHz 6-Core Intel Core i5
into Schitt Modi Multibit (or Cambridge Audio DacMagic Azur) via USB
and into AUX inputs of various (mostly vintage '60s/'70s) amplifiers/receivers (via switch)

Description Of Issue
Even when playing an entire album all the way through (no changes in format or resolution between tracks), there’s a slight delay that cuts off the first approximately 0.2 seconds of each track. I can see the red marker move to start playing the track, but the sound does not begin until slightly into the track (see attachment).

If the track has a second or so of silence before the music begins, this is not a problem, but if not it chops off the beginning and I have to use |< to re-start it properly. After looking around at other people’s similar problems, I tried setting a 1000 millisecond delay for changing resolution/format, but that doesn’t address the issue.

Is there a way to get Roon to buffer the next track before it starts playing, or to add a second or two to tracks to give Roon time to catch up? Not sure what the best approach would be…


I had the same problem. It seemed to start with the ‘improved’ buffer handling that was introduced in V1.7.

QA couldn’t recreate it, so good luck.

Hi @Jim_Emerson,

Does this behavior also occur with System Output of the Mac Mini?

Can you share a screenshot of Device Setup as well as the Signal Path when playing to this device?

That’s another perplexing question. I’m not sure what “System Output” means here. “Device Setup” has never worked for me – Roon either recognizes devices or keeps looking for them and never finds them. I have noticed that, since I added a bunch of new music several days ago, Roon has been “analyzing” my library and that has made response times quite slow, so I wonder if that might have something to do with it. I’ll attach screenshots below, but here’s my basic setup:

The MacMini (I named it MacMini Server) in my home office is the Core, attached to hard drives with my music files on them. It’s also running Roon Server, for reasons I no longer recall. In my main listening room (living room) I have another MacMini (2018) running Roon Bridge and Roon Server (again, I don’t recall why), and connected to the Core via WiFi. This MacMini 2018 is connected to a DAC via USB. I usually control the system wirelessly using a laptop running Roon. Here’s what the setup looks like from the Remote laptop:

Hi @Jim_Emerson,

Can you please share a screenshot of what you see when you open up the spinner for more information?

System Output should start playback to the selected audio device’s internal sound mixer, which usually outputs to the PC’s built-in speakers. Can you please check to see if the same issue occurs there or just on the Modi USB DAC?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.