First attempt at RasPi roon bridge not working. "We're ready. Roon is RUNNING"

I downloaded the latest image file (20210131-ropieee-ose_rpi234-stable.bin) and installed etcher. I tried to install the image (using both the .bin and the compressed versions) and got a failure message. I tried this several times and the microsd card is now non-functional. Ordered some new microsd cards and a SmartQ reader and after several days tried again.

This time I used RUFUS to install the image. In RUFUS when I to to select the image, only the zipped version shows as an option. Installation seemed to work.

Inserted the microsd card into the Raspberry pi 4 and attached OEM 7" touchscreen and Topping d10 DAC. Powered it up. It went through several reboots, and it eventually reads “We’re ready. Ropieee is RUNNING”.

This seems like a good result, but I cannot see the device in ROON and I cannot log onto the device using the UI. It appears to be camped on, but that doesn’t show any http ports open.

I assume I am doing something wrong, can anyone tell me how to go forward?

The “non-working” microsd card doesn’t show up in RUFUS either. I would try to go back to etcher, but by all indications it ruined a microsd card.


So you had internet connection during installation?

Have you tried reaching the web interface via ‘http://ropieee.local’ in your browser?

The IP address… are you sure this is correct? Is this in line with what you would expect?

Thanks for the reply.

Yes, internet was connected during the installation. At some point the display reported a “successful connection”.

No I am not completely sure of the IP address, but that is the only one that came alive when I brought up the Pi.

I am not sure why, but my machines aren’t able to resolve things like http://ropieee.local Never have

ok. That could be the case if it’s a windows machine.

If it says ‘up and running’ you should be able to connect to it’s web interface.
What you can do is try with an app like ‘fing’ which shows you connected devices.

OK, progress… I moved to a different location on my network (was going through an access point, now directly into the switch on the router) and got a message about “bad value for hidepid” but it still says it made a connection to the internet.

I now get a message “Update found!” when checking for updates, and finally the last message says “We’re ready. Roon is RUNNING”

It seems to have gotten to a different state, as now I see something that has landed (dhcp) at I downloaded andd installed “fing” and it finds this as well.

I now try to climb into the UI via Google Chrome and get to a UI page! However, the page says:


Installation failed!

Unfortunately the installation has failed.

This can have several reasons, but this is the most common:
* RoPieee requires internet connection during installation, so please make sure there’s an ethernet cable connected to the unit.

You need to reflash!

Relative to the re-flashing, I would like to understand more about what I saw originally. When I downloaded the latest I was expecting an .IMG file, but got a .BIN file instead. ok.

I have no idea what the problem is/was with etcher, but I am reluctant to use it. Afraid it will render another microsd card useless. is this a red herring?

I had more success when I switched to RUFUS, but it doesn’t recognize .BIN files, and only will allow me to pick the .XZ (compressed) file.

Thanks again for the help!

OK, more progress. I saw there was a new version of etcher available and I downloaded it. They released a new version in the last day or so (was 1.5.115, now 1.5.116).

I went through the flashing process with a new microsd and it completed the process just fine.

I then loaded it into the RasPi4 and it went through the process of booting and it gets past the
“We’re ready. Roon is RUNNING” message and shows a Ropieee splash screen.

It then tells me that it had trouble connecting to the ROON core… but I am hoping I can figure that out through the UI.

That is all good. You need to follow the instructions on the screen (configure the zone in the display tab and enable the extension)

Configured as you described, and it is working great. Thank you for your help, just ordered another RasPi to build another bridge.


Harry, another question. I built another using a Raspberry pi 3+, a HifiBerry DAC2 PRO, and a 7" touchscreen. If it is connected via ethernet I can crawl in and change the settings. One of the things I am wanting to do is run it wireless, so I go to that tab, enable wireless, and point it to the appropriate wireless network.

When I pull the ethernet cable I lose connectivity, and doing a reboot it hangs when it is trying to find an internet connection.

Is there something I am doing wrong in trying to turn on the wireless?


well, by turning the wireless off and on, selecting a different wifi, I was able to get it connected. Wish there was a nice enclosure for this combo, something that doesn’t have the wires sticking up from the top!


another question… can the power supply that came with the 3+ drive the pi, the touchscreen, and the DAC2 PRO hat, or do I need more than one power supply?