First-Time Roon Server Install Questions on QNAP HS-251+


(Lorin Chevalier) #1

I’m a Roon newbie (RoonNube?) with today being my first day of Roon membership and my first attempt to install Roon. I seem to be stuck mid-install, which probably means I’m doing something wrong. :thinking:

Here’s what I’m trying to do. My music library lives on a QNAP HS-251+, which pre-dates my Roon membership. The HS-251+ has two 1GB SSD drives, both of which are configured as data drives (no RAID mirroring). I separately backup my music library on both a USB drive and in the cloud on Microsoft OneDrive. The HS-251+ has an Intel Celeron J1900 @ 2.00 GHz with 1891 MB of RAM. I know this falls under the recommended specs for a QNAP NAS running Roon Server. But since this is where my music library currently lives, I figured I’d give it a try before looking to replace the NAS. My DAC is a Moon 280D with MiND2 and is “Roon-ready”.

I downloaded and installed the Roon Server from the QNAP App Center. The install appears to have worked with the Roon Server app now showing Status = Running, Version = 1.5 Build 363 (stable), and QPKG-Version = 2018-06-14. Interestingly, the Roon Server app only lists a single Connected Audio Device = HDA Intel PCH. Should it be showing the Moon 280D here as well?

Next, I attempted to install from Google Play the Roon Remote for Android on my smartphone. The install appears to have worked… sort of. When I opened the app, it opened to the “Choose your Roon Core” screen and immediately identified my QNAP HS-251+ as the location of the Roon Core. Immediately below where it shows the device name “QNAP-HS-251”, it shows a yellow circle and the word “Initializing…” To the right of that is a blue button that says “Connect” but appears to be “greyed out” and doesn’t respond to tapping on the button. At the bottom of the screen is a link that says “Configure Roon OS devices on your network”. Tapping that link opens a window that says “Configure Roon OS” and “Searching for devices…” and shows an animated Roon logo, presumably to show search progress. It’s now been almost 90 minutes and that screen has not changed save for the continued animation on the Roon logo, and there’s no indication that any “devices” have been found. Granted, I’m not sure what “devices” the Roon Remote app is actually searching for, so I’m not sure what “success” should look like here.

So this is where I’m now stuck and not sure what to try next. Apologies for the long post, but wanted to document everything I thought was relevant. Any recommendations will be greatly appreciated and I’ll be more than happy to contribute to @crieke 's coffee fund in return for assistance! :grinning:

Thanks!
Lorin


(Henry) #2

Firstly restart the QNAP device.
Secondly the MIND2 should potentially appear under networked devices. Ensure it has the latest firmware downloaded. If it appears it will still need to be enabled in the Roon menu. I don’t know what it might require in the Moon device menu.


(Ged) #3

Have you connected to the roon server from any other client like a PC.


(Lorin Chevalier) #4

Henry – thanks for your response. Following your advice, I did restart the QNAP device. However nothing appears to have changed. The Roon Remote for Android is still in mid-initialization with no reference to the Moon DAC w/ MiND2 as a networked device, and no way to view my music library via the Roon Remote app.

It occurred to me, however, that I may not have “connected” the Roon Server on the QNAP with the Roon Remote on my smartphone with my Roon account. I created my Roon account via the Roon website on my laptop, but did not install any Roon software on my laptop. Furthermore, neither the Roon install routine on the QNAP nor the Roon install routine on my smartphone asked me for my Roon account credentials. Not sure if this is required, but seems odd to me.

I decided not to install the Roon software on my Windows 10 laptop for fear that creating a Roon Server on the laptop would somehow conflict with the Roon Server on the QNAP. I couldn’t tell from the Roon Download instructions on the Roon website if I could only install a Roon Remote on my laptop without having the install routine automatically install the full Roon Server application, so I’ve not tried that as yet. I’m wondering if this could be part of the problem I’m experiencing?


(Lorin Chevalier) #5

Ged – thanks for your response. No, I have not connected to the Roon Server from any other client device. I provided more information in that regard in my response just now to @Henry_McLeod. Do you think that could be part of the problem I’m experiencing?


(Lorin Chevalier) #6

Forwarding this question to @support. I’m still stuck as explained in my prior posts and hoping to get this resolved so I can actually get Roon up and running and give it a test-drive before my credit card gets charged this coming Sunday. Thank you!


#7

@Lorin_Chevalier, the HS-251+ has only 2GB of memory. This may be the problem as Roon uses quite a bit of memory (I think the min requirement or recommendation is 4GB). Try running Roon Core on your Win 10 laptop and point Roon to your music on the Qnap. This will get you started. You will have no problems switching to a different Core later.

EDIT: How big is your library? The “Initializing…” can be a sign that Roon is busy indexing your music folder…


(Noris) #8

Hello @Lorin_Chevalier,

Thanks for pinging us regarding this issue. As others have mentioned, that QNAP looks a bit underpowered to run Roon so I would suggest trying Roon on your Windows 10 laptop first. You can get this up and running by installing the All-in-one version of Roon.

I would also suggest that you take a look at our Roon User Guide and Roon FAQ for any specific information you may require. Any information not included in those links, feel free to ask and we can assist.

Thanks,
Noris


(Lorin Chevalier) #10

Thank you @noris and @ogs. I guess sometimes the passage of time can help too! Upon reading Ogs’ post, I re-checked the Roon Remote on my smartphone. Sure enough, 5 days after initial install, it had finished Initializing and the Connect button was no longer greyed out. Tapping on Connect took me to the login screen… then allowed me to configure my system including selecting the Moon DAC… and it’s been smooth sailing from there and I’m up and running!

Love the Roon interface and content and the sound is great! No immediate additional issues with the QNAP, but I half expect its 2 GB memory to have adverse effects somewhere down the road, as you both suggested. At that point I plan to upgrade to a higher powered QNAP. Thanks again for your support!