Fix for recurring authorization prompt

Thank you Christopher, just a question … with 571 the scheduled backup fail (Authentican failure), do you think it could be related with the same issue you have fixed (QNAP TVS-882)? Best regards. Stefano.

Hi @Stefano_Aldini,
I have not noticed any issues with scheduled backups here and and see no connection to the recurrent Roon authentication prompt.
My scheduled backup had been done properly last night. (TVS-473e & TVS-471)

Is it consistent if you stop/start Roon Server again?

Thank you for the answer, I noticed this beaviour 3 days ago just after the update to 571 and again today (backup scheduled every 3 days). Every evening I switch off the NAS … if I ask to execute the Job manually, the process start with no issue … Next time I will copy the error message but more or less it reports an authentication problem
Best regards
Stefano

Thank you Christopher! Installed (manually) witout a flaw.

i just got the same message on my qnap 253be core

@crieke
i also noticed roon was logged out at that point
and i needed to login to roon again
this happend twice since the last 571 build (automatic log off)

image

Hi @goat,
Did you update the QNAP Roon Server App on TS-253be to 2020-06-19 as well?
It also looks like, your database destination for the backups is located within the database directory (Path in screenshot: RoonServer -> RoonServer -> Backup -> RoonBackups). It’d advice to use a dedicated folder (e.g. its own shared folder) for the backup).

Here is an example of my backup folder:

1 Like

@crieke i just updated manually to the latest version on QNAP

and thanks for pointing out the backup location
i’ll change this as well

Hi, I have installed the fix released from Christopher to solve the request of login at every boot af the Nas and, since then, the backup has failed no more. I can tell you if it is a side effect or what else but that"s it…

Can = can’t…

@crieke Hi Christopher, I got the same recurring authorization prompt problem with my system. Are you going to issue a quick fix for Synology NAS as well? Thanks!

My system,
Roon Server Build 571
NAS: DS3617xs running DSM 6.1.7

Hi @Jeff_Zhang,
I did not notice the issue on my Synology so far.
I have released a new Synology spk for testing a few days ago, which also includes the changes I made for QNAP and ASUSTOR.

Hi @crieke ,

Thanks for reply.

The issue happened after I switched my Roon Server from Synology 1515+ to 3617xs, and the Server software (all the remotes as well) was updated to build 571 when I start using new Roon Server. BTW, I did install 3617xs server with the new Synology spk you released on June 24.

So I’m not sure if it is caused by software updating or server switching but assume is the software (build 571) as the issue is quite similar with the other users mentioned here.

The symptom now is every time after the NAS is powered on, I need to login to my Roon account via the remote and unauthorize the Roon server before it really start working. Appreciate your further look into this. If needed I’ll open a separate thread in #support.

Thanks again!

Hi Christopher, unfortunately the update does not work for me. My remote prompts me to connect to the Roon server on my NAS. After providing the required credentials, I’m prompted to unauthorize my NAS. Seems like my remote tries to set up a core of its own. This issue started to occur since the last firmware update of my QNAP NAS.

My system:
QNAP TVS-473e, Firmware: 4.4.3.1354
Roon-Server Version 1.7 (build 571)
Roon remotes on Mac OS and iPhone

I would be very grateful for any help.

Best
Wolfgang

Hi @Wolfgang_Jekeli,
Click “Unauthorize” (bzw. im deutschen “Deautorisieren”) and you should be back authorised (I know, this might seem paradoxic).
The Roonlabs servers, think your core is authorized, but the device actually is not authorized as the authorization was not saved properly. So you need to click unauthorize button in order to authorize it again.
And this time (as you have performed the qpkg-update of RoonServer) it should be saved correctly and it won’t reoccur. :wink:

Hi @crieke,
Thank you for your quick reply. I have followed your advice. Now I can connect to the server with Roon remote on iPhone. However there is still an issue with my Roon remote on Mac. With Roon remote on Mac, I can connect to the Roon server exactly once. When I quit Roon remote on Mac and try to restart it, it won’t restart but fail on trying to do so. After restarting the Roon server, my Roon remote on Mac will again connect once and fail on the second and every next try.

Thanks in advance for your support!

Best
Wolfgang

The Official updated QNAP Roon App is now available in the App Centre.

3 Likes

Hi @crieke, @Scotav,

Everything works fine now. Thank you very much for your help & engagement.

Best
Wolfgang

1 Like