FLAC single unseen in my iTunes Artist Library

Apple MacMini M1 OS 11.1 8GB Ram / 256GB SSD
Directly connected to an Orbi Router
Music streams over wi-fi to a Bluesound Node 2i which is connected to the amp via RCA L/R plugs

I drug a FLAC single in my Music folder (via iTunes) into the Artist file in iTunes. The file track in Roon shows that it’s there but it isn’t visible when I open the the Artist file. Only the ALAC files appear.

Do I need to change the file to ALAC in order for it to be seen? I’ve tried using the Roon editing controls (Fix Tracks etc.) but am having no success there. The file is visible in Roon but not in that particular file which I named “Artist Name - Singles”

Any help would be greatly appreciated. Thank you!

iTunes doesn’t recognize FLAC, you’re gonna have to externally covert it to ALAC.

I discarded the FLAC version, downloaded an ALAC version, and placed it in the Artist’s folder in the iTunes app yet it still doesn’t appear there. Is there a way to get Roon to display it? The file path in Roon correctly shows the file there but it isn’t displayed as one of the tracks in that folder.

Drag drop he folder containing the alac files onto the itunes interface window, so that the tracks get added to the itunes database. Itunes will not automatically find them.

Hi @Mark_C,

Thanks for reaching out! Just to confirm here - you’re having an issue with this ALAC file appearing in Roon, correct? Can I please ask that you send me the affected media file for review via private message (upload to dropbox/google drive -> click my name -> message)? Any issues sending the file, just let me know!

Both the FLAC and ALAC files appeared in Roon but not where I manually placed them. After deleting the FLAC version, I downloaded an ALAC version of the song and manually drug it into the Artist’s folder in my iTunes Library which resides in my Music folder which Roon watches. My issue was that even though Roon showed the correct file path for that song (where I placed it), it did not appear within that folder but rather only in the “Recent Activity - Added” section. I was finally able to put the song where I wanted to via the “Merge Album” process. Not the easiest way in my opinion to accomplish this task but at least it worked. Drag and Drop would be a great new feature. Thanks!

Hi @Mark_C,

Thanks for letting us know you were able to re-download the track and resolve this issue!

It sounds like the metadata for the album might have caused it to be improperly identified.

Drag and Drop should be working in Roon, when you try to drag a file over Roon asks you where to save it if you have multiple storage locations, are you saying this wasn’t working on your end?

I was trying to drag the file, within the Roon iPad app, from the Artist’s “Top Tracks” to one of the Artists “Main Albums”. That’s what I couldn’t accomplish and was referring to in my Drag and Drop comment. Thanks!

1 Like

Hi @Mark_C,

Thanks for clarifying the behavior, I originally thought you were referring to importing files into Roon via Drag-and-Drop, which should be working as expected.

If you wish to have Drag-and-Drop in other parts of Roon, please submit a feature request regarding this, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.