FLAC Stuttering to X45Pro

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details

1Gb Ethernet connection
Devices are side by side into 1Gb switch

Connected Audio Devices

Cocktail Audio X45Pro

Library Size


Description of Issue

There is an intermittent stuttering issue with streaming FLAC files from X45Pro.
The higher the resolution the more the frequent the issue occurs.
With playing the files locally on the X45Pro zero issues.
Problem does not occur playing WAV
No DSP settings or processing enabled.

Hey @Jake_Paternoster,

Thanks so much for getting in touch and sharing the issue you’ve ran into. We’re very sorry about the trouble, but, rather than dwell on that, we’d love to help :nerd_face:

I was wondering if you’ve tried rebooting both the Nucleus and the X45 Pro? This would mean:

  • Quit Roon (on the Nucleus)
  • Turn off the device
  • Unplug it for a few minutes
  • Plug it back in
  • Turn on the device
  • Launch Roon
  • Connect the Cocktail

Does it help?

Also, we were hoping you could try this test: playing music via HDMI instead? Do you experience this issue? Or, can you stream music via a remote you have - is there any stuttering?

1 Like

Thanks for the reply,
We have tried restarting both devices fully with no change in result unfortunately.

Have not been able to test with HDMI or through the remote (Android tablet)
Would prefer to get it operating correctly in its current configuration.

EDIT: The X45 Pro HDMI is only audio out not audio in.

Is the X45Pro a very recent purchase?

If I read its spec correctly it seems to have a rather ancient ARM CPU (‘ARM Cortex-A9’) in it that would give me considerable cause for concern these days for hi-res streaming.

Think iPad 2 era from 10 years ago.

I have had the X45Pro since it first came out, and have never had stuttering problems, so I doubt it is at fault.

It’s my understanding that the decoding is done on the roon then streamed to the X45 Pro, so not sure why the codec seems to be the only variable that causes this to happen.

I guess another test would be to spin up roon on another device other than the nucleus and import the same library and see if that has any effect.

Are you by any chance using a roon nucleus @Neil_Russell?

In the last 6 months or so, yes.

As mentioned previously though, the files play perfectly on the X45 Pro itself.
Only when streamed through roon does it stutter.
WAV plays fine through roon as well, only FLAC has this issue.

No, I run my Roon core on a Dell XPS8930 pc with all my local files on two NAS units connected to the router via AQ Ethernet cables as is the PC. I have Qobuz for streaming. I do not use any DSP. I have done all firmware updates for the X45PRO.

Thanks for that, it really helps.
I’ve done the firmware update on the X45 Pro as well.

All the files at the moment are stored on the X45 Pro drives themselves, so I think the next logical choice is take the nucleus out of the equation and see if there is any change.

Hi @Jake_Paternoster,

Do you have any files stored locally on the Nucleus? Or do you have a USB drive you could connect to the Nucleus?

Currently the way this would work is the files would go from the X45 to the Nucleus and then back to the X45 — I’m wondering if having local files on the Nucleus would result in any difference.

1 Like

Hey Dylan,

Have purchased a drive to test this also, just waiting for restrictions here to ease so can go install it. I would have thought that the larger WAV files would create more of a problem rather than the FLAC as files as they are smaller.

I have setup a very cheap NUC with roon and imported the library from the X45 Pro. There has been no reported stuttering at all, so I think there is something up with the Nucleus.

The NUC is grossly underpowered compared to the Nucleus and is located further away from the X45 Pro going through another switch as well to get to it.

Is there any guides to reinstall the OS from scratch on the Nucleus? or some debug logs we can retrieve to take a look at?


Hi @Jake_Paternoster

What OS do you have installed on the NUC?

Is it connected to the network in a different way? Is there a switch or anything in the path to the Nucleus that isn’t there for the NUC?

You can reinstall the OS from the Nucleus Web Administration Interface. It’s unlikely that this would result in any change, but it’s worth a try!

As for diagnostics — Please note the exact local time + date when this issue next occurs and the name of the track that was playing and upload your Roon Logs by using these instructions. The best way to get them over to me would be via Dropbox / Google Drive, but if you don’t have either service please let me know and I can provide alternate upload instructions.

What OS do you have installed on the NUC?

Windows 10

Is it connected to the network in a different way? Is there a switch or anything in the path to the Nucleus that isn’t there for the NUC?

The NUC is further away from the X45 Pro as its off under the stairs in the house. It goes through an extra switch to get to the X45 Pro. The Nucleus is sitting beside the X45 Pro, plugged into the same switch.

It’s unlikely that this would result in any change

Didn’t think so either, but at this stage willing to give anything a try.

I will grab the logs and upload them and see what the reveals.

1 Like

Thanks, @Jake_Paternoster - Definitely let us know when you’ve sent the logs and I’ll take a look!